Search found 10 matches

by fryfrog
27 Jun 2018, 15:55
Forum: Extension scripts
Topic: [PP-SCRIPT] Change downloaded folder rights
Replies: 8
Views: 11499

Re: [PP-SCRIPT] Change downloaded folder rights

I liked how well @wusa's handled settings and errors, but @dime's is really the right way to fix it because files and folders need different permissions to work correctly. So I combined them and I think it is a slight improvement on both. :) #!/bin/bash ##############################################...
by fryfrog
13 Oct 2015, 17:48
Forum: Support
Topic: Apache Reverse Proxy w/ Auth Broken w/ v16.0
Replies: 11
Views: 4800

Re: Apache Reverse Proxy w/ Auth Broken w/ v16.0

This is what my reverse proxy config looks like. I don't do auth for my internal LAN and nzbget doesn't have a password, everything works great on the LAN. When coming from the outside, apache handles auth and then nzbget doesn't work. I bet if I made the nzbget user/pass the same as the htdigest, i...
by fryfrog
13 Oct 2015, 00:17
Forum: Support
Topic: Apache Reverse Proxy w/ Auth Broken w/ v16.0
Replies: 11
Views: 4800

Re: Apache Reverse Proxy Broken w/ v16.0

But r1439 does *not* work.

And here is the diff -BurN of r1420 vs. 1439 and that blurb in util.js is in there.

https://ptpb.pw/rHF5
by fryfrog
13 Oct 2015, 00:16
Forum: Support
Topic: Apache Reverse Proxy w/ Auth Broken w/ v16.0
Replies: 11
Views: 4800

Re: Apache Reverse Proxy Broken w/ v16.0

Both of those versions work.
by fryfrog
12 Oct 2015, 23:14
Forum: Support
Topic: Apache Reverse Proxy w/ Auth Broken w/ v16.0
Replies: 11
Views: 4800

Re: Apache Reverse Proxy Broken w/ v16.0

The last working version was the last stable release, 15.something. I ran the binary installer and stuck it in a test dir, 16 behaved exactly the same as the Arch install (which isn't surprising, since they do basically nothing to the install) and 15 worked fine. I logged into 16 and stripped the au...
by fryfrog
12 Oct 2015, 22:30
Forum: Support
Topic: Apache Reverse Proxy w/ Auth Broken w/ v16.0
Replies: 11
Views: 4800

Re: Apache Reverse Proxy Broken w/ v16.0

I'm on arch, editing /usr/share/nzbget/webui/util.js and tried # and /* */ and actually deleting the suggested code (with an nzbget restart for good measure), but it doesn't make any difference. if (XAuthToken !== undefined) { xhr.setRequestHeader('X-Auth-Token', XAuthToken); // Remove default autho...
by fryfrog
12 Oct 2015, 21:59
Forum: Support
Topic: Apache Reverse Proxy w/ Auth Broken w/ v16.0
Replies: 11
Views: 4800

Apache Reverse Proxy w/ Auth Broken w/ v16.0

My apache reverse proxy doesn't work after upgrading to v16. It works fine when port forwarded over ssh and it worked fine on my local network, but testing it from work it doesn't work anymore. My other stuff still works fine and nothing has changed recently with apache. Screen Shot 2015-10-12 at 2....
by fryfrog
05 Sep 2014, 05:52
Forum: Support
Topic: Permissions issue on new install
Replies: 4
Views: 4640

Re: Permissions issue on new install

I *think* the problem might have been my UMask maybe? I think I had it at 775 and tried 0775, when I noticed some files that were just --------w. So I set it back to the default of 1000. I suspect the tmp file was getting these permissions, but the cleanup erased it and I never actually saw one in t...
by fryfrog
04 Sep 2014, 17:31
Forum: Support
Topic: Permissions issue on new install
Replies: 4
Views: 4640

Re: Permissions issue on new install

I also gave 14 testing a shot, pretty sure it wasn't going to help and it didn't. I double checked ps output to confirm it was running as nzbget user and it was. The power is off at my house where the system is, but once it comes back up I'll give that a test. Should I just go ahead and locate the w...
by fryfrog
03 Sep 2014, 23:27
Forum: Support
Topic: Permissions issue on new install
Replies: 4
Views: 4640

Permissions issue on new install

I'm trying to get NZBGet working to replace SABnzbd, but am having what seems to be an obvious permissions issue. But for the life of me, I can't figure out why. The daemon runs as the user 'nzbget' with a group of 'nzbget' but is also in the group 'users'. The users home directory is 755 and this i...