[New Feature] Android installer

Discuss newly added features or request new features.
SteveWaters
Posts: 8
Joined: 02 Aug 2016, 19:37

Re: [New Feature] Android installer

Post by SteveWaters » 03 Aug 2016, 14:59

hugbug wrote:
  1. As you may see from this thread there is generally no interest to this theme.
    Since my previous post from "25 Apr 2016" there is no a single feedback to two features made specifically for android.
I'm sorry to say yes sir, I did see that. It's to bad there isn't more interest.
hugbug wrote:[*]As for android installer app to my knowledge it works flawlessly; the only reason to update it would be to change the version number to stable. But who cares? (see item 1)[/list]

It works for me as well, but it shuts down on me from time time. I'm sure that its a setting on my end though. Do you know where the option is to buy the add free is? Thank you.

hugbug
Developer & Admin
Posts: 6701
Joined: 09 Sep 2008, 11:58
Location: Germany (NRW)

Re: [New Feature] Android installer

Post by hugbug » 03 Aug 2016, 15:06

SteveWaters wrote:to buy the add free
I guess we are talking about different programs.
For official NZBGet for Android see the first post of this topic. If you installed from Play store that's a different program, a port of NZBGet made by a third-party developer.

If you have problems with official version please write back and we'll try to fix this. Please provide more info about your hardware and OS version.

glphvgacs
Posts: 1
Joined: 30 Jul 2014, 16:17

Re: [New Feature] Android installer

Post by glphvgacs » 09 Aug 2016, 15:24

i'm using the android installer on nexus and get 'Could not resolve hostname xxx.xxx.xxx: ErrNo -2, Name or service not known.'
dns works fine on this phone and other nzb [leecher] clients work fine the xxx.xxx.xxx
any idea?
btw, might help, 'Check for Updates' also fails,

UPDATE0: i get this on pushing the 'Check for updates': Could not resolve hostname nzbget.net: ErrNo -2, Name or service not known
UPDATE1: it seems dns problem , getaddrinfo() perhaps? using ip addr, connection is successful.

hugbug
Developer & Admin
Posts: 6701
Joined: 09 Sep 2008, 11:58
Location: Germany (NRW)

Re: [New Feature] Android installer

Post by hugbug » 09 Aug 2016, 16:57

Which exact android version?
Nzbget version?

The issue was reported before but the error message was different and incorrect due to a bug in the error reporting. Now we have at least correct error message (Name or service not known), which corresponds to dns lookup issue. That doesn't mean your device has general dns issues (other programs work fine). Nzbget is compiled into static binary and the dsn lookup code integrated into nzbget binary seems to be not compatible with newer android versions. It works fine on my decice with android 4.3 though. Moreover this is the same code which works in nzbget on all other linux systems.

A lot of experiments may help to identify the cause and fix the issue. If someone wants to do (a lot of) testing please get in touch with me via nzbget@gmail.com.

SteveWaters
Posts: 8
Joined: 02 Aug 2016, 19:37

Re: [New Feature] Android installer

Post by SteveWaters » 10 Aug 2016, 15:01

I launch the app and click "Install daemon". The daemon shows as not running, and I reboot try to install again with the same outcome. I also have a Nexus 6 root only. I can create bug reports if that helps? Thank you.

hugbug
Developer & Admin
Posts: 6701
Joined: 09 Sep 2008, 11:58
Location: Germany (NRW)

Re: [New Feature] Android installer

Post by hugbug » 10 Aug 2016, 15:16

"Install daemon" only installs, it doesn't start nzbget.
After you clicked on "install" were any messages shown? A success or failure message should be displayed.

To start daemon after installing use "Start daemon".

SteveWaters
Posts: 8
Joined: 02 Aug 2016, 19:37

Re: [New Feature] Android installer

Post by SteveWaters » 10 Aug 2016, 17:33

hugbug wrote:"Install daemon" only installs, it doesn't start nzbget.
After you clicked on "install" were any messages shown? A success or failure message should be displayed.
Yes sir, it installs with no issues.

hugbug wrote:To start daemon after installing use "Start daemon".
I have tapped that, the pop up says it started but it still shows that its not at the top. The install, and start daemon is still active, but the others are still grayed out. I'm sorry I should have put in all the info.
Attachments
Screenshot.png
Screenshot_2.png
Screenshot_3.png

hugbug
Developer & Admin
Posts: 6701
Joined: 09 Sep 2008, 11:58
Location: Germany (NRW)

Re: [New Feature] Android installer

Post by hugbug » 10 Aug 2016, 18:38

Oh, that means the daemon has stopped shortly after the start.
Please check if there is something in the log-file. Its path is like /sdcard/data/nzbget/nzbget.log.

SteveWaters
Posts: 8
Joined: 02 Aug 2016, 19:37

Re: [New Feature] Android installer

Post by SteveWaters » 10 Aug 2016, 19:29

I hope a zip file is ok?
Attachments
nzbget.zip
(487 Bytes) Downloaded 23 times

hugbug
Developer & Admin
Posts: 6701
Joined: 09 Sep 2008, 11:58
Location: Germany (NRW)

Re: [New Feature] Android installer

Post by hugbug » 10 Aug 2016, 19:40

Maybe there is a problem in status detection.
Message "Binding socket failed for 0.0.0.0: ErrNo 98, Address already in use" suggest that the daemon is running.
Try opening http://localhost:6789/ in web-browser.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest