How to start download

Get help, report and discuss bugs.
Post Reply
lantura
Posts: 8
Joined: 17 Mar 2014, 23:42

How to start download

Post by lantura » 18 Mar 2014, 00:05

I have installed NZBget on a raspberry without any (for me visible) errors. Webgui starts, messages shows that nzbget 12.0 daemon-mode is running, newsserver is configured, 2 files are waiting for download with status "Queued". And here is the problem: I can't change the status of these two files to "Download", if I click on "Resume" a short message "Resumed" is shown but the status of the files is still "Queued".

Any hints how I can start the download? Can I check the connection to the nes server with NZBget?

Thanks for any help.

hugbug
Developer & Admin
Posts: 7402
Joined: 09 Sep 2008, 11:58
Location: Germany

Re: How to start download

Post by hugbug » 18 Mar 2014, 00:29

Please post your config file ( via pastebin), remove passwords first.

lantura
Posts: 8
Joined: 17 Mar 2014, 23:42

Re: How to start download

Post by lantura » 18 Mar 2014, 06:31


hugbug
Developer & Admin
Posts: 7402
Joined: 09 Sep 2008, 11:58
Location: Germany

Re: How to start download

Post by hugbug » 18 Mar 2014, 08:21

Nothing suspicious in the config, all looks OK.
It's not news server config problem because if it can't reach the server the status still would be "downloading" and error messages would be printed to the messages tab.

Are you sure the program is not paused, is the main round button green (not orange)? Are there any messages on the messages tab? Can you please send me screenshot:
  • downloads (the first) tab;
  • messages tab;
  • speed limit dialog - click on speed indicator near round button (with the plane or truck icon);
  • statistics dialog - click on remaining time indicator below speed indicator;

lantura
Posts: 8
Joined: 17 Mar 2014, 23:42

Re: How to start download

Post by lantura » 18 Mar 2014, 16:59

Downloads & messages tab
Attachments
downloads.png
downloads tab
message.png
messages tab

lantura
Posts: 8
Joined: 17 Mar 2014, 23:42

Re: How to start download

Post by lantura » 18 Mar 2014, 17:00

speed limit dialog & statistics dialog
Attachments
speed limit.png
speed limit dialog
speed limit.png (5.18 KiB) Viewed 2114 times
statistics.png
statistics dialog
statistics.png (9.79 KiB) Viewed 2114 times

hugbug
Developer & Admin
Posts: 7402
Joined: 09 Sep 2008, 11:58
Location: Germany

Re: How to start download

Post by hugbug » 18 Mar 2014, 21:01

Something must be wrong with server1.connections although the config file looks OK, strange. Try adding second news server with the same credentials.

lantura
Posts: 8
Joined: 17 Mar 2014, 23:42

Re: How to start download

Post by lantura » 18 Mar 2014, 22:18

Now downloading works, I have copied nzbget.conf from /etc/ to /usr/local/share/nzbget/.
The /etc/ file had the server credentials, the /usr/local/share/ didn't had it.
I noticed that because in "Settings - Paths" the ConfigTemplate shows to "/usr/local/sharenzbget/nzbget.conf". But any change in settings which required a "Save all changes" shows the message "Could not save configuration in /etc/nzbget.conf. Please check file permissions."
I don't have deep linux knowledge. Maybe a chmod will solve this problem. But I don't know which permission is required for nzbget.conf in /etc.

hugbug
Developer & Admin
Posts: 7402
Joined: 09 Sep 2008, 11:58
Location: Germany

Re: How to start download

Post by hugbug » 18 Mar 2014, 22:28

lantura wrote:I have copied nzbget.conf from /etc/ to /usr/local/share/nzbget/
This is bad. The /usr/local/share/nzbget/nzbget.conf must be unchanged template file supplied with NZBGet. If you modify this file you will have other issues.

Keep your config in /etc/nzbget.conf and set permissions to it:

Code: Select all

chmod +w /etc/nzbget.conf
This should make file writable for NZBGet.

You can also put the config file anywhere and then use command line parameter -c <path-to-config>:

Code: Select all

nzbget -s -c /home/user/nzbget.conf

lantura
Posts: 8
Joined: 17 Mar 2014, 23:42

Re: How to start download

Post by lantura » 18 Mar 2014, 23:05

I have changed this.
Thank your for your support

Post Reply

Who is online

Users browsing this forum: No registered users and 9 guests