v14 crashes

Get help, report and discuss bugs.
hugbug
Developer & Admin
Posts: 7418
Joined: 09 Sep 2008, 11:58
Location: Germany

v14 crashes

Post by hugbug » 21 Nov 2014, 11:57

There are few topics with reports about often crashes in v14. Currently it looks like the devices with ARM CPU are most affected but this needs to be verified.

If you experience crashes in v14 too please post info in this topic. This topic is for crashes in v14 only. If you have issues with older program versions please report in another topic. If you use v14 on a NAS or other non-pc-device and don't have crashes - this info can be helpful, please post here too.

When posting in this topic (for the first time in the topic) please provide following information:
  • device model where NZBGet runs on, for NAS-devices the exact model number is necessary, especially for Synology devices, where every number or letter or a plus-character in the model name does matter;
  • CPU type (x86, ARM. etc);
  • RAM (total);
  • please mention if you have terminal access to the device (may help to obtain more info);
  • where you get NZBGet package (downloaded from NZBGet web site, downloaded from other source - what source?, compiled yourself);
  • have you used v13 before? did it work better? do you still have access to v13?
  • how often the crashes occur? if you would want to provoke a crash how long would it take (the shorter the better)?
  • please disable article cache (option ArticleCache) and quick par-verification (option ParQuick) until the cause is found;
The perfect person would be someone who can provoke a crash easily and who can compile on his own. In that case he could try (many) different testing versions of v14 to find the revision where the issue started to happen.

Please subscribe to this topic for faster communication.

Craig_T
Posts: 26
Joined: 12 Nov 2014, 17:08

Re: v14 crashes

Post by Craig_T » 21 Nov 2014, 13:46

Model: Synology DS112J
CPU: Marvell Kirkwood mv6281 1.0Ghz ARM (Marvell ARMADA 300)
RAM: 128MB
Terminal Access: Yes
Source: I used SynoCommunity Package
V13: Yes, no crashes but slower POST download times, No more access as it was package install.
How often: At least once a day, maybe more when I run downloads.
Article Cache: Already disabled.
QuickPar: I have now disabled this.

I am willing to do any testing needed and I am learning to compile so I may be able to do it from tomorrow.

sppedst343
Posts: 9
Joined: 21 Nov 2014, 22:41

Re: v14 crashes

Post by sppedst343 » 21 Nov 2014, 22:53

device model ; Synology DiskStation DS1813+
CPU: INTEL Atom D2700
RAM (total); 2 Gb
Terminal access to the device (may help to obtain more info); Yes
Source; SynoCommunity Package
V13: Yes i used v13 before. Had no problems with v13, problems started with v14. No access to v13 anymore
how often the crashes occur? if you would want to provoke a crash how long would it take (the shorter the better)? I think i usually had 2 crashes a day. Random times, no clue when exactly the problem occurs, so not possible to provoke right now
please disable article cache (option ArticleCache) and quick par-verification (option ParQuick) until the cause is found; article is already disabled for a few days and still crashes occur. par disabled right now

now im not capable to compile now but if necessary i will try to learn it.

king80
Posts: 38
Joined: 28 Oct 2014, 10:43

Re: v14 crashes

Post by king80 » 21 Nov 2014, 23:47

sppedst343 wrote:device model ; Synology DiskStation DS1813+
CPU: INTEL Atom D2700
RAM (total); 2 Gb
Terminal access to the device (may help to obtain more info); Yes
Source; SynoCommunity Package
V13: Yes i used v13 before. Had no problems with v13, problems started with v14. No access to v13 anymore
how often the crashes occur? if you would want to provoke a crash how long would it take (the shorter the better)? I think i usually had 2 crashes a day. Random times, no clue when exactly the problem occurs, so not possible to provoke right now
please disable article cache (option ArticleCache) and quick par-verification (option ParQuick) until the cause is found; article is already disabled for a few days and still crashes occur. par disabled right now

now im not capable to compile now but if necessary i will try to learn it.
same exact info, only difference i got 1513

seem this is a problem with the synology package?

jimboe
Posts: 39
Joined: 08 Jan 2013, 05:50

Re: v14 crashes

Post by jimboe » 22 Nov 2014, 06:52

Model: Seagate BlackArmor 110 running hacked Debian Lenny
CPU: Marvell Feroceon, 800 MHz, ARM926EJ-S, Sheeva CPU Core Technology
RAM: 128MB
Terminal Access: Yes
Source: Compiled
V13: Last version used was v11 self compiled- then HD crashed (~Mar 2014) and now rebuilt NAS straight to v14-- I'm pretty sure this was a problem under v11 for me as well (come home, daemon gone)
How often: Complex answer.
  • ArticleCache=100 > ArticleCache=50 > ArticleCache=25 ( ?? ArticleCache=0 ?? (see notes) )
  • Dumping many (20-30) nzbs into the queue at once may exacerbate the issue
  • Using the debugging version I complied MOST CERTAINLY exacerbates the issue greatly. At AC=50 & NO debug, I can run perhaps for 12-24 hrs continuously without nzbget barfing. With debugging version on, perhaps every 20-120 mins it crashes.
    Supposition: Perhaps the massive amount of logging going on overloads the system.? Due to this, I believe it may be hard to analyze the OP issue because we don't know if nzbget is bailing due the issue of the OP, or due to debugging itself overloading the system (if that theory is even possible/correct)
(notes: I just was running with AC=0 on the debugging version, and about 32 nzbs loaded up. nzbget disappeared after 52 minutes; AND no core dump- just gone. (log on it's way to you hugbug.) The download now continues for the past 2.5 hrs.. I have my doubts as to whether it would've crashed if I were using the non-debugging version..

Also, from what I recall when I ran this same hardware, nearly identical OS/sw setup from mid 2013 up to the crash in Mar 2014, and with my vers 11, I recall this same behavior-- nzbget daemon disappearing after anywhere from 1 to several hours , or perhaps making it through the night. So I'd say this problem has existed for a while now.
Article Cache: 0
QuickPar: enabled.

king80
Posts: 38
Joined: 28 Oct 2014, 10:43

Re: v14 crashes

Post by king80 » 22 Nov 2014, 08:38

i noticed everytime it crashes and i re-open it...the second it opens a download finish up...it usually crashes at the last second of unpacking

the first thing it does everytime after a crash is this
INFO Sat Nov 22 2014 11:35:15 Unrar: UNRAR 5.20 beta 3 freeware Copyright (c) 1993-2014 Alexander Roshal
INFO Sat Nov 22 2014 11:35:15 Unpacking Constantine.S01E05.720p.HDTV.X264-DIMENSION

hugbug
Developer & Admin
Posts: 7418
Joined: 09 Sep 2008, 11:58
Location: Germany

Re: v14 crashes

Post by hugbug » 22 Nov 2014, 14:14

@king80:
when it crashes next time please check the log-file (before restarting NZBGet) and post here the few last messages. May be we'll see a pattern.

sppedst343
Posts: 9
Joined: 21 Nov 2014, 22:41

Re: v14 crashes

Post by sppedst343 » 22 Nov 2014, 14:21

tonight another crash with ArticleCache and ParQuick disabled. also same as with king80 after starting nzbget again there was a unpacking
i first backup the log before restarting. last line from log was Sat Nov 22 02:50:48 2014 WARNING Cancelling unpack for ... due to errors

hugbug
Developer & Admin
Posts: 7418
Joined: 09 Sep 2008, 11:58
Location: Germany

Re: v14 crashes

Post by hugbug » 22 Nov 2014, 14:50

@sppedst343: please send me the log-file at nzbget@gmail.com.

It'll be very helpful if you could compile on your own. We could add more logging or similar. And you could also compile debug-version which generates callstack on segfault and also core-files. Please see this topic for links about compiling for synology.

sppedst343
Posts: 9
Joined: 21 Nov 2014, 22:41

Re: v14 crashes

Post by sppedst343 » 22 Nov 2014, 15:08

hugbug wrote:@sppedst343: please send me the log-file at nzbget@gmail.com.

It'll be very helpful if you could compile on your own. We could add more logging or similar. And you could also compile debug-version which generates callstack on segfault and also core-files. Please see this topic for links about compiling for synology.
log is send. i dont tink it wil help because it is only simple logging. if i need some other settings please let me know
im watching know how to complie. need a vm first because im running windows 64 bit

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests