Duplicate entries in nzbget.conf after SavingSettings

Get help, report and discuss bugs.
Post Reply
buggix
Posts: 6
Joined: 11 Feb 2016, 11:44

Duplicate entries in nzbget.conf after SavingSettings

Post by buggix » 11 Feb 2016, 11:56

Hi all,

On my Qnap Nas i installed QNZBget Package from this forum post http://forum.qnap.com/viewtopic.php?t=109452
It seems to be the current version of NZBGet 16.4.

Usenet Download is working fine. But everytime i edit the settings from nzbget, there are duplicate entries in nzbget.conf. And The WebUI displays these seetings double. Unpacking also fails, when there are duplicates in the settings.

I delete the duplicate entries with vi. Then i reload the webui, edit some settings and save them. After that there are again my duplicate entries.

after googling, i found some identical problems from other users. The solution for them was to check ConfigTemplate Setting. My ConfigTemplate Setting is set to "/opt/QNZBGet/share/nzbget/nzbget.conf". For me it looks good.

Can anybode help?

Sorry for my bad english :/

hugbug
Developer & Admin
Posts: 7396
Joined: 09 Sep 2008, 11:58
Location: Germany

Re: Duplicate entries in nzbget.conf after SavingSettings

Post by hugbug » 11 Feb 2016, 12:12

Where is your config-file stored? Make sure it isn't the file set in ConfigTemplate.

buggix
Posts: 6
Joined: 11 Feb 2016, 11:44

Re: Duplicate entries in nzbget.conf after SavingSettings

Post by buggix » 11 Feb 2016, 12:44

i´m not sure which nzbget.conf file is realy in use... how can i find this out?

using the command "find -name nzbget.conf" i can see three files located here...

./etc/nzbget.conf
./share/HDA_DATA/.qpkg/QNZBGet/share/nzbget/nzbget.conf
./share/HDA_DATA/NZBGet/nzbget.conf

Regards

hugbug
Developer & Admin
Posts: 7396
Joined: 09 Sep 2008, 11:58
Location: Germany

Re: Duplicate entries in nzbget.conf after SavingSettings

Post by hugbug » 11 Feb 2016, 12:51

In web browser - http://nzbget-host:nzbget-port/jsonrpc/config, look for "ConfigFile" (at the top).

buggix
Posts: 6
Joined: 11 Feb 2016, 11:44

Re: Duplicate entries in nzbget.conf after SavingSettings

Post by buggix » 11 Feb 2016, 12:52

"Name" : "ConfigFile",
"Value" : "\/etc\/nzbget.conf"

buggix
Posts: 6
Joined: 11 Feb 2016, 11:44

Re: Duplicate entries in nzbget.conf after SavingSettings

Post by buggix » 11 Feb 2016, 12:53

"Name" : "ConfigTemplate",
"Value" : "\/opt\/QNZBGet\/share\/nzbget\/nzbget.conf"

buggix
Posts: 6
Joined: 11 Feb 2016, 11:44

Re: Duplicate entries in nzbget.conf after SavingSettings

Post by buggix » 11 Feb 2016, 14:49

"Name" : "ConfigFile",
"Value" : "\/etc\/nzbget.conf" -> Symlink point to /share/HDA_DATA/.qpkg/QNZBGet/share/nzbget/nzbget.conf

"Name" : "ConfigTemplate",
"Value" : "\/opt\/QNZBGet\/share\/nzbget\/nzbget.conf" No Symlink!

But it looks like that both files are identical... Last edited is the same time, Filesize also same... I think there is a bug in SaveSettings Function.
Also i can see my settings for my newsserver in both files... i think my settings should be only in the configfile and the configtemplate must me a clean template

Can anybody help?

hugbug
Developer & Admin
Posts: 7396
Joined: 09 Sep 2008, 11:58
Location: Germany

Re: Duplicate entries in nzbget.conf after SavingSettings

Post by hugbug » 11 Feb 2016, 15:21

I can assure you there is no bug in save settings.

But there can be a bug in QNAP package, which installs NZBGet.

Option ConfigTemplate must point to unchanged (important!) template which comes with NZBGet.

Suggestion - remove QNAP package and install the program using official installer - Installation on Linux.

buggix
Posts: 6
Joined: 11 Feb 2016, 11:44

Re: Duplicate entries in nzbget.conf after SavingSettings

Post by buggix » 11 Feb 2016, 19:06

You are right! there must be something wrong with the QNZB Package from qnap forum.
now I installed the original version per command tool and it works greatful :)

Thank you for your answers.

I also post a link to this thread in the qnap forum. Perhaps the Qnap package builder will read this and will repair his qpgk package.

Regrads

daviddp4
Posts: 1
Joined: 19 Feb 2016, 22:40

Re: Duplicate entries in nzbget.conf after SavingSettings

Post by daviddp4 » 19 Feb 2016, 22:46

Hi,

I had the same error on my Qnap, and now it works with the original version.
Thank you for your post !!!
Do you know how to start nzbget on boot ?
Witch the QNZB package, it was automatic but with the official install, it doesn't work...

Thanks

David

Post Reply

Who is online

Users browsing this forum: No registered users and 7 guests