Upgrade to V17 and slow download

Get help, report and discuss bugs.
hugbug
Developer & Admin
Posts: 7627
Joined: 09 Sep 2008, 11:58
Location: Germany

Re: Upgrade to V17 and slow download

Post by hugbug » 31 Jul 2016, 04:48

Please also compare speed and CPU usage when downloading with one and more connections without SSL (use a legal Linux iso).

As another test put nzbget.exe from v17 into installation directory of v16 under a different name (nzbget17.exe) and test if it works better this way.

Apprectiate all your testing. I wouldn't bother you if I could reproduce the issue on my own.

flash3d
Posts: 11
Joined: 30 Jul 2016, 11:09

Re: Upgrade to V17 and slow download

Post by flash3d » 31 Jul 2016, 10:17

hugbug wrote:
When only one news-server connection is active?
40% but only 3 MB/s download.

All above numbers also in comparison with v16.
Only checked cpu wile ago and it was around 40-50%
40% for one connection and 3 MB/s seems to be way too much. Do you mean v16 utilize 40-50% CPU for one connection as well? How fast goes v16 with one connection?
v16 was using 40-50% for 24 connections total.
Haven't tried v16 one connection.

Now I have: around 2,25 MB/s and around 10% cpu

flash3d
Posts: 11
Joined: 30 Jul 2016, 11:09

Re: Upgrade to V17 and slow download

Post by flash3d » 31 Jul 2016, 10:31

hugbug wrote:Please also compare speed and CPU usage when downloading with one and more connections without SSL (use a legal Linux iso).

As another test put nzbget.exe from v17 into installation directory of v16 under a different name (nzbget17.exe) and test if it works better this way.

Apprectiate all your testing. I wouldn't bother you if I could reproduce the issue on my own.
I'm not using SSL.
Just tested v17 nzbget in 16.4 dir and same result, cpu 100% and slow download.

No problems with helping, just trying to tackle the issue.

hugbug
Developer & Admin
Posts: 7627
Joined: 09 Sep 2008, 11:58
Location: Germany

Re: Upgrade to V17 and slow download

Post by hugbug » 31 Jul 2016, 10:47

Can you please with SSL? With one connection and with all. It should use more CPU but if it works better with SSL that would be a pointer.

hugbug
Developer & Admin
Posts: 7627
Joined: 09 Sep 2008, 11:58
Location: Germany

Re: Upgrade to V17 and slow download

Post by hugbug » 31 Jul 2016, 11:11

Few more ideas.
1. Check option ContinuePartial (disable it).
2. As a separate test disable option Decode and test with one connection in both vesions, what was speed and CPU usage in each version? Please note that an nzb you use for this test can not be completed (e. g. don't do that test with a 40GB nzb you care of).

flash3d
Posts: 11
Joined: 30 Jul 2016, 11:09

Re: Upgrade to V17 and slow download

Post by flash3d » 31 Jul 2016, 11:19

hugbug wrote:Can you please with SSL? With one connection and with all. It should use more CPU but if it works better with SSL that would be a pointer.
SSL exactly same result:
16.4 all ok
17 high CPU and slow download.

Both with 1 and 24 connections.

flash3d
Posts: 11
Joined: 30 Jul 2016, 11:09

Re: Upgrade to V17 and slow download

Post by flash3d » 31 Jul 2016, 11:59

hugbug wrote:Few more ideas.
1. Check option ContinuePartial (disable it).
2. As a separate test disable option Decode and test with one connection in both vesions, what was speed and CPU usage in each version? Please note that an nzb you use for this test can not be completed (e. g. don't do that test with a 40GB nzb you care of).
1. no change.
2. v17 7% 1,4 MB/s
v16,4 7% 1,8 MB/s

hugbug
Developer & Admin
Posts: 7627
Joined: 09 Sep 2008, 11:58
Location: Germany

Re: Upgrade to V17 and slow download

Post by hugbug » 31 Jul 2016, 12:22

Let me summarize:

One connection, Decode=yes
V16: 2.25 MB/s, 10% CPU
V17: 3 MB/s, 40% CPU

One connection, Decode=no
V16: 1.8 MB/s, 7% CPU
V17: 1.4 MB/s, 7% CPU

From that it sems the decoding is the problem. Can you please do these tests once again to confirm?

Do you have by any chance another computer where you could test?

Can you please try the very first testing version of v17 (https://github.com/nzbget/nzbget/releas ... 17.0-r1660)? That would narrow down the search a little.

Thank you for patience.

flash3d
Posts: 11
Joined: 30 Jul 2016, 11:09

Re: Upgrade to V17 and slow download

Post by flash3d » 31 Jul 2016, 12:30

hugbug wrote:Let me summarize:

One connection, Decode=yes
V16: 2.25 MB/s, 10% CPU
V17: 3 MB/s, 40% CPU

One connection, Decode=no
V16: 1.8 MB/s, 7% CPU
V17: 1.4 MB/s, 7% CPU

From that it sems the decoding is the problem. Can you please do these tests once again to confirm?

Do you have by any chance another computer where you could test?

Can you please try the very first testing version of v17 (https://github.com/nzbget/nzbget/releas ... 17.0-r1660)? That would narrow down the search a little.

Thank you for patience.

Will do all tests after F1 is finished :D

flash3d
Posts: 11
Joined: 30 Jul 2016, 11:09

Re: Upgrade to V17 and slow download

Post by flash3d » 31 Jul 2016, 14:09

Test ver. 17 is having the same issue, let me do the "one connection" tests again.
Update in a few minutes.

Post Reply

Who is online

Users browsing this forum: No registered users and 11 guests