Could not flush directory buffers

Get help, report and discuss bugs.
Post Reply
bugmenot
Posts: 1
Joined: 07 Dec 2016, 17:33

Could not flush directory buffers

Post by bugmenot » 07 Dec 2016, 17:38

I reinstalled nzbget because I found out I was still on v13 but now I get this warnings every second:

Code: Select all

WARNING	Wed Dec 07 2016 18:35:26	Could not flush directory buffers for file /mnt/downloads/.nzbget/queue/stats into disk: Invalid argument
WARNING	Wed Dec 07 2016 18:35:25	Could not flush directory buffers for file /mnt/downloads/.nzbget/queue/queue into disk: Invalid argument
The mount is on a windows machine.
Any way to fix those warnings without disabling FlushQueue?

hugbug
Developer & Admin
Posts: 7643
Joined: 09 Sep 2008, 11:58
Location: Germany

Re: Could not flush directory buffers

Post by hugbug » 07 Dec 2016, 21:28

What's a point of disabling warnings? Disable FlushQueue instead, it doesn't work anyway.

It's also a bad idea to store queue on a remote disk.

Nox
Posts: 1
Joined: 09 Dec 2021, 14:36

Re: Could not flush directory buffers

Post by Nox » 09 Dec 2021, 15:53

hugbug wrote:
07 Dec 2016, 21:28
It's also a bad idea to store queue on a remote disk.
Could you explain why? No problems with NZBGET with this "remote disk setup", but massive with SABNZBD. Wonder Why. :mrgreen: Only was I could find is this: https://forum.nzbget.net/viewtopic.php?p=12734#p12734

But still no idea, I would be interested in the technical background.

hugbug
Developer & Admin
Posts: 7643
Joined: 09 Sep 2008, 11:58
Location: Germany

Re: Could not flush directory buffers

Post by hugbug » 09 Dec 2021, 18:21

Network disk may become unavailable due to network errors. If this happens during saving of the queue it may get corrupted on the disk.

Post Reply

Who is online

Users browsing this forum: No registered users and 10 guests