Unable to log in with Chrome 70 in incognito mode

Get help, report and discuss bugs.
Post Reply
whocarez
Posts: 4
Joined: 28 Oct 2018, 19:30

Unable to log in with Chrome 70 in incognito mode

Post by whocarez » 28 Oct 2018, 19:42

Hey,

I usually use nzbget from Chrome in incognito mode. I just noticed that now I just get a 401 each time I open the web page. This is with Chrome Version 70.0.3538.77 on Windows 7. This was working until recently, possibly also in Chrome 69. It seems to be working in Chrome outside of incognito and in Firefox 63 (in both normal and private mode).

Just to be sure, I did second and clean installation of nzbget-21.0-testing-r2220 on the same computer, and on a different one. Both installations are on Linux, Debian 9.3. The result is the same.

It would be nice to have nzbget working in incognito, that is how I normally use the application. Any suggestions?

hugbug
Developer & Admin
Posts: 7091
Joined: 09 Sep 2008, 11:58
Location: Germany

Re: Unable to log in with Chrome 70 in incognito mode

Post by hugbug » 28 Oct 2018, 19:51

My guess is cookies are not allowed. Try to change chrome settings.
If option FormAuth in nzbget is active please test without it.

whocarez
Posts: 4
Joined: 28 Oct 2018, 19:30

Re: Unable to log in with Chrome 70 in incognito mode

Post by whocarez » 29 Oct 2018, 18:20

Hi again. Both cookies and pop-ups are allowed for the site. I even added an exception just to be sure. I believe the 401 appears before any cookies are set, there is just no basic HTTP authentication. Anyway, cookies are not blocked in incognito, just not saved on exit, AFAIK.

However, I just tested with FormAuth=on, and that works in incognito. Strange.

hugbug
Developer & Admin
Posts: 7091
Joined: 09 Sep 2008, 11:58
Location: Germany

Re: Unable to log in with Chrome 70 in incognito mode

Post by hugbug » 29 Oct 2018, 18:25

With FormAuth=no does the dialog for basic http auth pop up?

whocarez
Posts: 4
Joined: 28 Oct 2018, 19:30

Re: Unable to log in with Chrome 70 in incognito mode

Post by whocarez » 29 Oct 2018, 19:02

Nope, it is never shown.

whocarez
Posts: 4
Joined: 28 Oct 2018, 19:30

Re: Unable to log in with Chrome 70 in incognito mode

Post by whocarez » 29 Oct 2018, 20:23

Anyway, it helped to create a new Chrome profile. Now everything (for now) is back to normal. Something must have been somewhat broken with basic http auth dialog in incognito. We will see if it lasts. Anyway, it is great to know that we have a web form option to login with, just in case.

I found the thread about it, https://github.com/nzbget/nzbget/issues/330 and it is fantastic that you listened to feedback and implemented this feature :) Thanks. To summarize, as workarounds in incognito this worked:

FormAuth=yes
http://username:password@localhost:6789/ <-- (also basic http auth, so possibly only showing the dialog box must have been broken)
http://localhost:6789/username:password/

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 4 guests