NZBGet & Sick Beard MP4 automator

Get help, report and discuss bugs.
Post Reply
ViolatingBunion
Posts: 4
Joined: 07 Dec 2018, 07:28

NZBGet & Sick Beard MP4 automator

Post by ViolatingBunion » 07 Dec 2018, 18:15

Ive been working on setting up the auto convertor and ive now hit a wall to which i need help.

Im getting this log error file.

Fri Dec 7 18:07:57 2018 INFO Move for My.Little.Pony.Friendship.is.Magic.S07E17.720p.WEB-DL.DD5.1.H.264-iT00NZ successful
Fri Dec 7 18:07:57 2018 INFO Executing post-process-script NZBGetPostProcess.py for My.Little.Pony.Friendship.is.Magic.S07E17.720p.WEB-DL.DD5.1.H.264-iT00NZ
Fri Dec 7 18:07:58 2018 INFO NZBGetPostProcess: Script triggered from NZBGet (11.0 or later).
Fri Dec 7 18:07:58 2018 INFO NZBGetPostProcess: 2018-12-07 18:07:58 - readSettings - INFO - C:\Python27\python.exe
Fri Dec 7 18:07:58 2018 ERROR NZBGetPostProcess: File processing failed.
Fri Dec 7 18:07:58 2018 INFO NZBGetPostProcess: Traceback (most recent call last):
Fri Dec 7 18:07:58 2018 INFO NZBGetPostProcess: File "C:\ProgramData\NZBGet\scripts\NZBGetPostProcess.py", line 203, in <module>
Fri Dec 7 18:07:58 2018 INFO NZBGetPostProcess: output = converter.process(inputfile)
Fri Dec 7 18:07:58 2018 INFO NZBGetPostProcess: File "C:/sickbeard_mp4_automator-master/mkvtomp4.py", line 189, in process
Fri Dec 7 18:07:58 2018 INFO NZBGetPostProcess: options = self.generateOptions(inputfile, original=original)
Fri Dec 7 18:07:58 2018 INFO NZBGetPostProcess: File "C:/sickbeard_mp4_automator-master/mkvtomp4.py", line 302, in generateOptions
Fri Dec 7 18:07:58 2018 INFO NZBGetPostProcess: info = Converter(self.FFMPEG_PATH, self.FFPROBE_PATH).probe(inputfile)
Fri Dec 7 18:07:58 2018 INFO NZBGetPostProcess: File "C:/sickbeard_mp4_automator-master/converter\__init__.py", line 254, in probe
Fri Dec 7 18:07:58 2018 INFO NZBGetPostProcess: return self.ffmpeg.probe(fname, posters_as_video)
Fri Dec 7 18:07:58 2018 INFO NZBGetPostProcess: File "C:/sickbeard_mp4_automator-master/converter\ffmpeg.py", line 413, in probe
Fri Dec 7 18:07:58 2018 INFO NZBGetPostProcess: '-show_format', '-show_streams', fname])
Fri Dec 7 18:07:58 2018 INFO NZBGetPostProcess: File "C:/sickbeard_mp4_automator-master/converter\ffmpeg.py", line 380, in _spawn
Fri Dec 7 18:07:58 2018 INFO NZBGetPostProcess: close_fds=(os.name != 'nt'), startupinfo=None)
Fri Dec 7 18:07:58 2018 INFO NZBGetPostProcess: File "C:\Python27\lib\subprocess.py", line 390, in __init__
Fri Dec 7 18:07:58 2018 INFO NZBGetPostProcess: errread, errwrite)
Fri Dec 7 18:07:58 2018 INFO NZBGetPostProcess: File "C:\Python27\lib\subprocess.py", line 640, in _execute_child
Fri Dec 7 18:07:58 2018 INFO NZBGetPostProcess: startupinfo)
Fri Dec 7 18:07:58 2018 INFO NZBGetPostProcess: WindowsError: [Error 5] Access is denied
Fri Dec 7 18:07:58 2018 INFO NZBGetPostProcess: 2018-12-07 18:07:58 - autoprocess.sonarr - INFO - [INFO] Sonarr notifier started.
Fri Dec 7 18:07:58 2018 INFO NZBGetPostProcess: 2018-12-07 18:07:58 - autoprocess.sonarr - INFO - [INFO] Requesting Sonarr to scan directory 'D:\TV'.
Fri Dec 7 18:07:58 2018 INFO NZBGetPostProcess: 2018-12-07 18:07:58 - autoprocess.sonarr - INFO - [INFO] Sonarr response: queued.
Fri Dec 7 18:07:58 2018 INFO Post-process-script NZBGetPostProcess.py for My.Little.Pony.Friendship.is.Magic.S07E17.720p.WEB-DL.DD5.1.H.264-iT00NZ successful
Fri Dec 7 18:07:58 2018 INFO Collection My.Little.Pony.Friendship.is.Magic.S07E17.720p.WEB-DL.DD5.1.H.264-iT00NZ added to history

Has anyone set this up and had this issue?

Thank you.

hugbug
Developer & Admin
Posts: 7091
Joined: 09 Sep 2008, 11:58
Location: Germany

Re: NZBGet & Sick Beard MP4 automator

Post by hugbug » 07 Dec 2018, 18:43

It probably tries to execute ffmpeg.exe for which you need to set correct path in script settings first.
I maybe wrong, I never used that script, only a guess from error message.

ViolatingBunion
Posts: 4
Joined: 07 Dec 2018, 07:28

Re: NZBGet & Sick Beard MP4 automator

Post by ViolatingBunion » 07 Dec 2018, 20:42

hugbug wrote:
07 Dec 2018, 18:43
It probably tries to execute ffmpeg.exe for which you need to set correct path in script settings first.
I maybe wrong, I never used that script, only a guess from error message.
HI Hugbug.

Have you setup the auto convertor with NZBGET?

Im looking for help in getting this up and running and i cant seem to get past this last hurdle.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests