Some, but not all, providers don't work with SSL

Get help, report and discuss bugs.
Post Reply
kledder
Posts: 2
Joined: 10 Dec 2018, 23:07

Some, but not all, providers don't work with SSL

Post by kledder » 10 Dec 2018, 23:21

I currently have 3 usenet providers: xsnews, newsdemon, usenetexpress. I would like to use SSL for all providers by inserting the port number 563 in the "Server[x]Port" field at "News-Servers" for each server respectively. The problem is that I'm getting a error message when I click "test connection" for 2 providers (xsnews and usenetexpress).
Connection test failed
Could not receive data on socket from news.usenetexpress.com: ErrNo 10060, A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
This only happens with UsenetExpress. Not with my other providers.
When using port 119 it says "connection successful" for all 3 providers.
Only Newsdemon works with port 563 to get SSL in NZBGet version 20.0.
I also tested port 564 for usenetexpress but no luck there either.

The odd thing is that they ALL work with port 563 for SSL in Binreader (another nzb client). What's going on and how do I get SSL connection for all 3 providers in NZBGet version 20.0?

hugbug
Developer & Admin
Posts: 7331
Joined: 09 Sep 2008, 11:58
Location: Germany

Re: Some, but not all, providers don't work with SSL

Post by hugbug » 10 Dec 2018, 23:34

What happen if you try download (instead of "test connection")?
Make sure the port is correct (read provider docs) and option Encryption of the server is active.
Please post error messages from real downloading.

kledder
Posts: 2
Joined: 10 Dec 2018, 23:07

Re: Some, but not all, providers don't work with SSL

Post by kledder » 12 Dec 2018, 00:30

I got it working now. I forgot to enable "encryption". I was used to just adding the right port in Binreader :). I'm new to NZBGet. Thanks for your reply.

Post Reply

Who is online

Users browsing this forum: No registered users and 7 guests