GUI stops responding, Win10

Get help, report and discuss bugs.
Post Reply
TSmythe
Posts: 3
Joined: 04 Jan 2019, 22:13

GUI stops responding, Win10

Post by TSmythe » 04 Jan 2019, 22:25

So I've had nzbget working for a couple weeks... But for some reason I can't quite figure out, I lose connectivity to the web interface. The CLI window shows it is still downloading, processing, etc...

If I click on Troubleshooting: Open Config file, it opens the ProgramData location. Searching my HD, I have nzbget.conf in that location and in C:\Users\All Users\[username]\NZBGet.

The web GUI does work for a while, sometimes like a day, before this happens.

I'm running a VPN, which seems to not like me using 127.0.0.1, so I use the PC's static IP address. Again it works fine for quite a while, and then no browser will connect. I get an error: "Firefox can’t establish a connection to the server at [ip address]"

I thought maybe something is going amiss with the VPN. So I disable, and even exit from it. Still no working GUI interface.

Today I installed some proxy software on the same computer, at port 8080. Just to test whether something (VPN) is interfering with network requests to this computer. The proxy software works fine, while the GUI isn't coming up.

I'm perplexed as to what is going on. I'd greatly appreciate any insight.

Thanks!

hugbug
Developer & Admin
Posts: 7124
Joined: 09 Sep 2008, 11:58
Location: Germany

Re: GUI stops responding, Win10

Post by hugbug » 06 Jan 2019, 01:51

Nzbget's web-server binds to ip-address (as set by option ControlIP). The binding happens only once when the program is started. Can it be that your VPN client software changes the network settings and also the local IP address?

TSmythe
Posts: 3
Joined: 04 Jan 2019, 22:13

Re: GUI stops responding, Win10

Post by TSmythe » 07 Jan 2019, 21:12

Thank you for your response. I do think it is something related to the VPN.

If I shut down my VPN and nzbget, fully - no processes running... and then re-start nzbget first, I seem to be able to connect fine. Start my VPN, and it then intercepts that traffic and re-routes it, everything is fine. I'll work with my VPN vendor to let them know something may be amiss. (Seems to happen often when the VPN disconnects, although I'm not sure if the VPN disconnecting is the cause - or both of these issues are just a symptom of some other PC network driver issue)

Regardless - it would be nice if I could start nzbget paused. There doesn't seem to be a way to do that?

Thanks again!

TSmythe
Posts: 3
Joined: 04 Jan 2019, 22:13

Re: GUI stops responding, Win10

Post by TSmythe » 08 Jan 2019, 13:08

My problem seems to be similar to this:

https://forum.nzbget.net/viewtopic.php?t=3318

I wonder if it is unrelated to the VPN as I can still access ports (like a proxy server) on my computer even when nzbget is unresponsive to the web interface.

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests