Saving/moving on Nas impossible...

Get help, report and discuss bugs.
Post Reply
telexxitfr
Posts: 12
Joined: 01 Apr 2019, 05:26

Saving/moving on Nas impossible...

Post by telexxitfr » 01 Apr 2019, 05:47

Hello...
My configuration :
Intel Nuc i7 with windows 10
NAS Qnap ts431

Nzbget is running on the nuc for speed on par check and unrar.
In startup, i create disk letter for directory shared on my nas, using 'net use z //192.168.1.25/....'
Z, E and G.
Under windows shell or explorer all can be access in read/write mode and create/delete directory... So full access...

BUT, nzbget don't want to move, write to....
I d set my destdir parameter as z:\

I always get this message kind :

Could not create directory z:\The.Enemy.Within.S01E04.720p.HDTV.x264-AVS\_unpack: could not create directory z:\: No such file or directory

But if i test under windows shell : mkdir z:\The.Enemy.Within.S01E04.720p.HDTV.x264-AVS\ work perfectly....

I d tested with network path, //192.168.1....... even \\192.168.1..... , instead of z:\ but same result....

What's the problem ?
Thanks for your help

hugbug
Developer & Admin
Posts: 7418
Joined: 09 Sep 2008, 11:58
Location: Germany

Re: Saving/moving on Nas impossible...

Post by hugbug » 01 Apr 2019, 06:44

telexxitfr wrote:
01 Apr 2019, 05:47
In startup, i create disk letter for directory shared on my nas, using 'net use z //192.168.1.25/....'
Is nzbget running as service or as application with tray icon?

If you run it as servcie it will not see your mount. Generally mounts with letters don't work well with services.

If nzbget runs as application, make sure it is started after the dirve is mounted. As a test, after the system is loaded and the drive is mounted and you can create directories there - then stop nzbget and start again as application (double click on nzbget.exe) and test how it works.

UNC-Paths like "\\192.168.1.1" should work in both app and service mode. Please try again and post the log.

telexxitfr
Posts: 12
Joined: 01 Apr 2019, 05:26

Re: Saving/moving on Nas impossible...

Post by telexxitfr » 01 Apr 2019, 07:08

path set to \\192.168.1.25\Telechargement like my Z: windows letter drive and get same error .....
permissions denied....unlike under windows shell where i can make directory, extract to z:\ .....
see my log attached....
NZBGET 20.0 run as service on my NUC

thanks for your help...

ps: NzbGet installed on NAS work ...but with low speed par2 and unrar (low processor speed) , so i prefer to do that on my NUC and move extracted files on NAS .....
Attachments
n143.log
(8.48 KiB) Downloaded 11 times

hugbug
Developer & Admin
Posts: 7418
Joined: 09 Sep 2008, 11:58
Location: Germany

Re: Saving/moving on Nas impossible...

Post by hugbug » 01 Apr 2019, 07:35

Did you make this test?
As a test, after the system is loaded and the drive is mounted and you can create directories there - then stop nzbget and start again as application (double click on nzbget.exe) and test how it works.
Please make the test with letter and with UNC-path.

telexxitfr
Posts: 12
Joined: 01 Apr 2019, 05:26

Re: Saving/moving on Nas impossible...

Post by telexxitfr » 01 Apr 2019, 08:01

work nice as application .....
so as service, user ID problem ? strange.....

so until service would be work, i'll start NZBGET as application.
thanks for your help

hugbug
Developer & Admin
Posts: 7418
Joined: 09 Sep 2008, 11:58
Location: Germany

Re: Saving/moving on Nas impossible...

Post by hugbug » 01 Apr 2019, 09:06

telexxitfr wrote:
01 Apr 2019, 08:01
work nice as application .....
Do both variants work - letter and UNC?

telexxitfr
Posts: 12
Joined: 01 Apr 2019, 05:26

Re: Saving/moving on Nas impossible...

Post by telexxitfr » 01 Apr 2019, 09:14

yes...work on UNC and letter

hugbug
Developer & Admin
Posts: 7418
Joined: 09 Sep 2008, 11:58
Location: Germany

Re: Saving/moving on Nas impossible...

Post by hugbug » 01 Apr 2019, 10:18

It seems the permissions on your NAS are configured to allow access to your own user account only (but not to Windows system account under which nzbget runs). Try following:
  1. use UNC in NZBGet settings.
  2. in Windows Services Management open properties of NZBGet service and on Log-on page change user to your own user account.

telexxitfr
Posts: 12
Joined: 01 Apr 2019, 05:26

Re: Saving/moving on Nas impossible...

Post by telexxitfr » 01 Apr 2019, 11:37

you're right...

created window user as on my NAS, and set the same user in nzbget service logon.

Now all work nice in service mode too....

great !

Big thanks !

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests