Permission issue - NZBGet on Debian throug Docker Compose

Get help, report and discuss bugs.
Post Reply
kevindd992002
Posts: 4
Joined: 07 May 2019, 09:02
Contact:

Permission issue - NZBGet on Debian throug Docker Compose

Post by kevindd992002 » 07 May 2019, 09:47

I have NZBGet's UMask set to 002. Anything it creates have the correct permissions. But files in rar packages sometimes have their own permissions and that makes permissions not consistent all through my NZBGet folder structure. How do I set unrar in NZBGet to ignore the permissions of file/folders inside a rar package and just apply the default permissions and follow NZBGet's UMask?

hugbug
Developer & Admin
Posts: 7302
Joined: 09 Sep 2008, 11:58
Location: Germany

Re: Permission issue - NZBGet on Debian throug Docker Compose

Post by hugbug » 07 May 2019, 10:13

Take a look at option UnrarCommand, it has an example for this.

kevindd992002
Posts: 4
Joined: 07 May 2019, 09:02
Contact:

Re: Permission issue - NZBGet on Debian throug Docker Compose

Post by kevindd992002 » 07 May 2019, 11:25

hugbug wrote:
07 May 2019, 10:13
Take a look at option UnrarCommand, it has an example for this.
Is that a switch?

hugbug
Developer & Admin
Posts: 7302
Joined: 09 Sep 2008, 11:58
Location: Germany

Re: Permission issue - NZBGet on Debian throug Docker Compose

Post by hugbug » 07 May 2019, 12:25

It's UnrarCmd, not UnrarCommand. In settings, section UNPACK.
Replace default "${AppDir}/unrar" with "${AppDir}/unrar x -ai". This should help.

kevindd992002
Posts: 4
Joined: 07 May 2019, 09:02
Contact:

Re: Permission issue - NZBGet on Debian throug Docker Compose

Post by kevindd992002 » 07 May 2019, 12:38

hugbug wrote:
07 May 2019, 12:25
It's UnrarCmd, not UnrarCommand. In settings, section UNPACK.
Replace default "${AppDir}/unrar" with "${AppDir}/unrar x -ai". This should help.
Great! I swear I've read this somewhere a few days ago and I'm glad there's confirmation here. Shouldn't that be the default setting though?

kevindd992002
Posts: 4
Joined: 07 May 2019, 09:02
Contact:

Re: Permission issue - NZBGet on Debian throug Docker Compose

Post by kevindd992002 » 07 May 2019, 13:14

No need for the ; (semi-colon) at the end of the syntax, right? In the example listed there, there's a semi-colon there.

hugbug
Developer & Admin
Posts: 7302
Joined: 09 Sep 2008, 11:58
Location: Germany

Re: Permission issue - NZBGet on Debian throug Docker Compose

Post by hugbug » 07 May 2019, 13:18

Yes, the semi-colon is strictly for page formatting; it's not part of the command.

Post Reply

Who is online

Users browsing this forum: No registered users and 8 guests