Problems adding NZB files

Get help, report and discuss bugs.
Post Reply
MrVideo
Posts: 38
Joined: 20 Mar 2019, 05:44

Problems adding NZB files

Post by MrVideo » 29 May 2019, 09:18

There are three problems when using the add files dialog:

1) If you fetch some NZB files, but hit cancel and then bring up the dialog again, there is no sign that there are files selected. You don't discover than until you add a NZB file. You could end up with a duplicate. I have that situation. If files are already there, when the dialog is brought up, they should be displayed. I know, duplicates are ignored when submitted.

2) When you add files and discover that there were some all ready there, there is no way to delete unwanted entries. At least, I haven't found a way. There needs to be a way to delete entries. Maybe it was entered by mistake.

3) If a NZB is in the queue, but the NZB file was deleted (because I had already downloaded it, so I do not know why it was in the cue), the program hangs trying to open a file that doesn't exist. The program should not hang, it should ignore the entry and remove it from the cue. I had to recreate the nzb file in order for nzbget not to hang.

MrVideo
Posts: 38
Joined: 20 Mar 2019, 05:44

Re: Problems adding NZB files

Post by MrVideo » 11 Jun 2019, 07:05

Please, will a developer respond to these problems.

I just ran into the issue again. I didn't know that nzbget didn't remove it from the queue after the job was done and I had removed the RAR file (in this case), only to discover that the RAR file is still in the queue. And now nzbget refuses to allow me to go any further unless I get the rar file again.

I finally got so frustrated that I shut down the server and cleaned out all of the files (except those in "completed") and restarted the server.

This needs to be fixed.

hugbug
Developer & Admin
Posts: 7396
Joined: 09 Sep 2008, 11:58
Location: Germany

Re: Problems adding NZB files

Post by hugbug » 11 Jun 2019, 07:42

Do not touch any files in QueueDir.

MrVideo
Posts: 38
Joined: 20 Mar 2019, 05:44

Re: Problems adding NZB files

Post by MrVideo » 11 Jun 2019, 07:51

hugbug wrote:
11 Jun 2019, 07:42
Do not touch any files in QueueDir.
Too late. It seemed to be to only thing that allowed me to get going again. By wiping everything out, it is as if I started the program for the first time.

As mentioned in the other posting about files hanging around, when a job is done, nzbget seems to not clean up after itself, resulting in space getting used up and the issues I'm running into.

MrVideo
Posts: 38
Joined: 20 Mar 2019, 05:44

Re: Problems adding NZB files

Post by MrVideo » 14 Jun 2019, 12:06

After cleaning out all of the directories (except for Completed), the job I ran consisted of three discs.

Now I'm adding four more discs and the first three are still being shown in the add GUI dialog box. Why? They were downloaded without any issues, yet, here they are again. And, like before, because I removed the NZB files, nzbget is now hanging because it can't find the NZB file.

Please, is this in the queue to be fixed?

hugbug
Developer & Admin
Posts: 7396
Joined: 09 Sep 2008, 11:58
Location: Germany

Re: Problems adding NZB files

Post by hugbug » 14 Jun 2019, 22:36

Sounds weird. What browser do you use? Please try a different one.

MrVideo
Posts: 38
Joined: 20 Mar 2019, 05:44

Re: Problems adding NZB files

Post by MrVideo » 16 Jun 2019, 08:31

hugbug wrote:
14 Jun 2019, 22:36
Sounds weird. What browser do you use? Please try a different one.
Opera 12.16

Switched to Vivaldi 2.5.1511.4 (snapshot)

That fixed it. Thanks. That was unexpected. Normally I know to switch to the Vivaldi browser when I end up having rendering issues. This didn't manifest itself as a rendering issue. It seemed more like a server issue. Obviously I was greatly mistaken and that the browser code is doing more than I expected.

Sorry to have been a PITA.

Post Reply

Who is online

Users browsing this forum: No registered users and 10 guests