Cannot get NZBGet to work after installing to a new computer

Get help, report and discuss bugs.
Post Reply
EnZioBe
Posts: 30
Joined: 18 Oct 2015, 14:37

Cannot get NZBGet to work after installing to a new computer

Post by EnZioBe » 12 Jun 2019, 15:22

Running Windows 10 Home.

I used to run NZBGet on a desktop PC (Windows 10 Pro), and I reinstalled it on a laptop. Now all my downloads fail at post-processing.

I installed Python 2.7 in C:\Python27
My paths are:
MainDir c:\Users\john\Documents\Donwloads\NZBGet
DestDir ${MainDir}\complete
InterDir ${MainDir}\intermediate
NzbDir ${MainDir}\nzb
QueueDir ${MainDir}\queue
TempDir ${MainDir}\tmp
ScriptDir ${MainDir}\scripts

Extension scripts:
Extensions Subliminal.py, videosort\VideoSort.py,nzbgetpp-master\unzip.py
Script order nzbgetpp-master\unzip.py, Subliminal.py, videosort\VideoSort.py
shell override .py=C:\Python27\python.exe

Videosort:
MoviesDir ${DestDir}/movies
SeriesDir ${DestDir}
DatedDir ${DestDir}/tv
OthertvDir ${DestDir}/tv
TV categories tv

I also have subliminal installed.
Both extensions are in a scripts directory in C:\Users\john\Documents\Donwloads\NZBGet\scripts. Videosort.py is in the videosort directory and subliminal.py is in the scripts directory.

Categories:
I have a category named series and DestDir is blank
Similarly for a category named Movies and another one named Music

I use Sonarr and the root directory for every series is C:\Users\john\Documents\Donwloads\NZBGet\complete\series\<series name>
Sonarr reports that multiple root folders are missing.

I would appreciate any assistance to fix this.

hugbug
Developer & Admin
Posts: 7418
Joined: 09 Sep 2008, 11:58
Location: Germany

Re: Cannot get NZBGet to work after installing to a new computer

Post by hugbug » 12 Jun 2019, 19:39

EnZioBe wrote:
12 Jun 2019, 15:22
Now all my downloads fail at post-processing.
Do they fail in nzbget or Sonarr doesn't recognise them? In the first case a log of one download would be helpful. Click on item in history, then button Log, then Save to file. Post it via pastebin.com.

EnZioBe
Posts: 30
Joined: 18 Oct 2015, 14:37

Re: Cannot get NZBGet to work after installing to a new computer

Post by EnZioBe » 13 Jun 2019, 07:00

Many thanks. I have the following information.

I pasted the log in https://pastebin.com/wMkQsXt8. I notice that the log mentions "Permission denied" somewhere toward the end. Could this be the cause of the problem?

When the downloading finished there was a post-process error indication under the History Status column. It happened that I moved away from the laptop for a minute and when I came back the Status had changed to Success!

Also the downloaded file ended up in C:\Users\john\Documents\Donwloads\NZBGet\complete\The Handmaids Tale\, but interestingly enough there was also a complete tree of all series that I'm following in the directory C:\Users\john\Documents\Donwloads\NZBGet\complete\series. All directories in it were empty, including The Handmaids Tale. I guess this must have been created by Sonarr, but I don't know how or why.

Ideally I would want the tv episodes to end up in the ...\complete\series\ subdirectory.

hugbug
Developer & Admin
Posts: 7418
Joined: 09 Sep 2008, 11:58
Location: Germany

Re: Cannot get NZBGet to work after installing to a new computer

Post by hugbug » 13 Jun 2019, 08:36

Code: Select all

c:\Users\john\Documents\Donwloads\NZBGet\intermediate\Killing.Eve.S02E08.1080p.BluRay.x264-ROVERS [9.#25\11.out.tmp to c:\Users\john\Documents\Donwloads\NZBGet\intermediate\Killing.Eve.S02E08.1080p.BluRay.x264-ROVERS [9.#25\killing.eve.s02e08.1080p.bluray.x264-rovers.r03: Permission denied
Looks like some process accesses intermediate files of nzbget during downloading, blocking them from moving into destination directory. Such as antivirus or media library manager. You should configure them to not scan nzbget directories.

EnZioBe
Posts: 30
Joined: 18 Oct 2015, 14:37

Re: Cannot get NZBGet to work after installing to a new computer

Post by EnZioBe » 13 Jun 2019, 12:28

Thank you for the advice. I use Bitdefender, but it didn't warn me about blocking anything related to NZBGet. I'll try and add it to the trusted programs anyway.

EDIT: In actual fact I found that I had already set Bitdefender to allow NZBGet. I'll investigate further.

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests