Page 1 of 1

"Cancelling hanging download"

Posted: 08 Sep 2019, 11:53
by davidkain001
Hi there,

I've been experiencing issues with NZBGet recently that I suspect are network related. I've done some Googling and basic troubleshooting, but I've hit a wall and am hoping folks here can help! I apologize if I've left out any obvious info, or missed basic troubleshooting steps. This is definitely out of my wheelhouse.

I'm running version 21.0 of NZBGet on Windows.

ISSUE: After adding an NZB to my queue, it will initially start downloading fine, but very soon after (within 1 minute) the speed drops dramatically from 15+MB/s to just a few KB/s. I then begin seeing errors in the logs, e.g.:

Code: Select all

Cancelling hanging download Preacher.S04E07.720p.WEB.h264-TBS-xpost\preacher.s04e07.720p.web.h264-tbs.mkv [256/1117] @ UsenetServer (NEWS.USENETSERVER.COM)
 Could not write to TLS-Socket: Connection closed by remote host
 Could not read from TLS-Socket: Connection closed by remote host
 Authorization for UsenetServer (NEWS.USENETSERVER.COM) failed: 502 Too many connection
 Connection to NEWS.USENETSERVER.COM failed: ErrNo 10060, A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
This happens for both Usenetserver and I've tried reducing the number of connections to 1, and for I also tried accessing their non-US servers. Given this is happening to both providers, I believe it's safe to assume the problem is on my end.

Next step I took was to ping Google, which I believe *is* showing a problem. Here's what I get on all machines on my network (ip addresses removed):

Code: Select all

Tracing route to []
over a maximum of 30 hops:

  1    <1 ms    <1 ms    <1 ms 
  2     8 ms     7 ms     7 ms  
  3     8 ms     8 ms     8 ms  
  4     8 ms     8 ms     9 ms  
  5     9 ms     9 ms     8 ms  
  6     9 ms    13 ms    13 ms  
  7     *        *        *     Request timed out.
  8     9 ms     9 ms     9 ms []
Results for were similar. Pinging anything except times out. Does this indicate a problem with my local network? This would make sense, as I've noticed issues with attempting to stream Original quality (very large) video on my home network recently. Regardless, this is where I'm stuck currently. Any help is much appreciated!

For reference, my network configuration is:

Code: Select all

Netgear CM1000 (modem)-------Google Wifi (router)-------Ethernet Switch-------PC
Thanks again! Really banging my head on this one.

Re: "Cancelling hanging download"

Posted: 09 Sep 2019, 12:38
by davidkain001
Hey folks,

Updating this thread in case anyone else runs into a similar issue. Turns out my issue (at least the one affecting NZBGet's ability to download) was not a network one after all. I'm pretty sure there's *also* something wonky going on with my network, but for now I'm at least functional again.

In my case, the issue was that I had changed a few PATHS to point to a non-local drive (InterDir, QueueDir, TempDir). I set these back to local, and I'm back in business.