TLS-Socket: error:1408F119:SSL routines:SSL3_GET_RECORD:decryption failed or bad record mac

Get help, report and discuss bugs.
NOTORIOUS VR
Posts: 7
Joined: 15 Jan 2017, 01:07

Re: TLS-Socket: error:1408F119:SSL routines:SSL3_GET_RECORD:decryption failed or bad record mac

Post by NOTORIOUS VR » 27 Sep 2019, 00:43

sanderj wrote:
23 Sep 2019, 15:32
I have no explanation for this, and I can't reproduce it, even after changing NZBget's cacert.pem

So ... time for you to do some induction and deduction:

Current nzbget (21?) with a fresh nzbget.conf. Method: download and unpack and run nzbget 21 in a seperate directory, using the fresh nzbget.conf in there. Does it still happen?
If so: older nzbget (20, 19) with fresh nzbget.conf ... does it sill happen?
tried with a fresh .conf file - still happens

tried with a fresh install of 21 - still happens

tried with a fresh install of 19.1 - still happens

sanderj
Posts: 144
Joined: 10 Feb 2014, 21:46

Re: TLS-Socket: error:1408F119:SSL routines:SSL3_GET_RECORD:decryption failed or bad record mac

Post by sanderj » 27 Sep 2019, 07:35

Wow. Then more rigourous: live-boot Ubuntu 18.04 from USB, install nzbget, do the same test ...

If it still happens, it is not in your system, but outside your system, so router, firewall, ISP, government, or PEBKAC. :twisted:

lasdjlasda
Posts: 16
Joined: 02 Mar 2015, 11:56

Re: TLS-Socket: error:1408F119:SSL routines:SSL3_GET_RECORD:decryption failed or bad record mac

Post by lasdjlasda » 27 Sep 2019, 15:25

NOTORIOUS VR wrote:
27 Sep 2019, 00:43
tried with a fresh .conf file - still happens

tried with a fresh install of 21 - still happens

tried with a fresh install of 19.1 - still happens
I did the same except try different version. I also have tried many different ciphers, RC4-MD5, AES128-SHA, AES256-SHA and now im running with the setting blank - not sure which cipher is used then. Still same error!

Curious; what openssl version do you have? I have:

Code: Select all

LibreELEC:~ # openssl
OpenSSL> version
OpenSSL 1.0.2q  20 Nov 2018

NOTORIOUS VR
Posts: 7
Joined: 15 Jan 2017, 01:07

Re: TLS-Socket: error:1408F119:SSL routines:SSL3_GET_RECORD:decryption failed or bad record mac

Post by NOTORIOUS VR » 28 Sep 2019, 13:11

lasdjlasda wrote:
27 Sep 2019, 15:25
NOTORIOUS VR wrote:
27 Sep 2019, 00:43
tried with a fresh .conf file - still happens

tried with a fresh install of 21 - still happens

tried with a fresh install of 19.1 - still happens
I did the same except try different version. I also have tried many different ciphers, RC4-MD5, AES128-SHA, AES256-SHA and now im running with the setting blank - not sure which cipher is used then. Still same error!

Curious; what openssl version do you have? I have:

Code: Select all

LibreELEC:~ # openssl
OpenSSL> version
OpenSSL 1.0.2q  20 Nov 2018
Version: OpenSSL 1.0.2g 1 Mar 2016

NOTORIOUS VR
Posts: 7
Joined: 15 Jan 2017, 01:07

Re: TLS-Socket: error:1408F119:SSL routines:SSL3_GET_RECORD:decryption failed or bad record mac

Post by NOTORIOUS VR » 28 Sep 2019, 13:12

sanderj wrote:
27 Sep 2019, 07:35
Wow. Then more rigourous: live-boot Ubuntu 18.04 from USB, install nzbget, do the same test ...

If it still happens, it is not in your system, but outside your system, so router, firewall, ISP, government, or PEBKAC. :twisted:
Doubt it is my firewall/router... but it could be my system (it's a very old VM).

I will report back when I setup NZBget on a fresh install of Ubuntu in a new VM.

lasdjlasda
Posts: 16
Joined: 02 Mar 2015, 11:56

Re: TLS-Socket: error:1408F119:SSL routines:SSL3_GET_RECORD:decryption failed or bad record mac

Post by lasdjlasda » 19 Oct 2019, 10:01

I got some debug logs which i have edited out the server name and article name out of! does this help at all? Do you need more? Any specifics? If so can i email you them privately instead of posting publicly?

Thanks :)
Thu Oct 17 10:58:38 2019 603 140371840038656 DEBUG Opening connection to eu.REDACTED_SERVER_NAME.com (NntpConnection.cpp:187:Connect)
Thu Oct 17 10:58:38 2019 603 140371898787584 DEBUG Scanner service work (Scanner.cpp:91:ServiceWork)
Thu Oct 17 10:58:38 2019 603 140371898787584 DEBUG Scanner service work: doing work (Scanner.cpp:105:ServiceWork)
Thu Oct 17 10:58:38 2019 603 140371898787584 DEBUG Disk service work (DiskService.cpp:51:ServiceWork)
Thu Oct 17 10:58:38 2019 603 140371898787584 DEBUG Disk service work: check disk space (DiskService.cpp:67:CheckDiskSpace)
Thu Oct 17 10:58:38 2019 603 140371898787584 DEBUG serviceInterval: 5, remaining: 5 (Service.cpp:80:Run)
Thu Oct 17 10:58:38 2019 603 140371898787584 DEBUG serviceInterval: 3600, remaining: 3380 (Service.cpp:80:Run)
Thu Oct 17 10:58:38 2019 603 140371898787584 DEBUG serviceInterval: 60, remaining: 22 (Service.cpp:80:Run)
Thu Oct 17 10:58:38 2019 603 140371898787584 DEBUG serviceInterval: 1, remaining: 1 (Service.cpp:80:Run)
Thu Oct 17 10:58:38 2019 603 140371898787584 DEBUG Waiting in ServiceCoordinator: 1 (Service.cpp:83:Run)
Thu Oct 17 10:58:38 2019 603 140371890394880 DEBUG Checking cache, Allocated: 64512000, FlushEverything: 0 (ArticleWriter.cpp:861:CheckFlush)
Thu Oct 17 10:58:38 2019 603 140371890394880 DEBUG Checking cache... nothing to flush (ArticleWriter.cpp:896:CheckFlush)
Thu Oct 17 10:58:39 2019 603 140369496880896 DEBUG Saving partial state for toy.story.4.2019.3d.1080p.bluray.x264-psychd.r24 (QueueCoordinator.cpp:959:SavePartialState)
Thu Oct 17 10:58:39 2019 603 140369496880896 DEBUG Saving FileState 105 to disk (DiskState.cpp:1177:SaveFileState)
Thu Oct 17 10:58:39 2019 603 140369496880896 DEBUG Saving queue progress to disk (DiskState.cpp:433:SaveDownloadProgress)
Thu Oct 17 10:58:39 2019 603 140369496880896 DEBUG Saving nzb progress to disk (DiskState.cpp:495:SaveProgress)
Thu Oct 17 10:58:39 2019 603 140369496880896 DEBUG Flushing data for file progress.new (DiskState.cpp:188:FinishWrite)
Thu Oct 17 10:58:39 2019 603 140370050537216 ERROR Could not read from TLS-Socket: error:1408F119:SSL routines:SSL3_GET_RECORD:decryption failed or bad record mac
Thu Oct 17 10:58:39 2019 603 140370050537216 DETAIL Article REDACTED_ARTICLE_NAME.r24 [89/131] @ REDACTED_SERVER_NAME NL - SSL - Highwinds/Eweka (eu.REDACTED_SERVER_NAME.com) failed: Unexpected end of article
Thu Oct 17 10:58:39 2019 603 140370050537216 DETAIL Downloading REDACTED_ARTICLE_NAME.r24 [89/131] @ REDACTED_SERVER_NAME NL - SSL - Highwinds/Eweka (eu.REDACTED_SERVER_NAME.com)
Thu Oct 17 10:58:39 2019 603 140370050537216 DEBUG Opening connection to eu.REDACTED_SERVER_NAME.com (NntpConnection.cpp:187:Connect)
Thu Oct 17 10:58:39 2019 603 140370050537216 DETAIL Article REDACTED_ARTICLE_NAME.r24 [89/131] @ REDACTED_SERVER_NAME NL - SSL - Highwinds/Eweka (eu.REDACTED_SERVER_NAME.com) failed, could not fetch article: k�5'��#�٘7zT,t͉�Cb3�6��w�_�gЂJF

Thu Oct 17 10:58:39 2019 603 140370050537216 DETAIL Downloading REDACTED_ARTICLE_NAME.r24 [89/131] @ REDACTED_SERVER_NAME NL - SSL - Highwinds/Eweka (eu.REDACTED_SERVER_NAME.com)
Thu Oct 17 10:58:39 2019 603 140370050537216 DEBUG Opening connection to eu.REDACTED_SERVER_NAME.com (NntpConnection.cpp:187:Connect)
Thu Oct 17 10:58:39 2019 603 140370050537216 DETAIL Article REDACTED_ARTICLE_NAME.r24 [89/131] @ REDACTED_SERVER_NAME NL - SSL - Highwinds/Eweka (eu.REDACTED_SERVER_NAME.com) failed, could not fetch article: �Ʉ�,��г���Q�ChJ#���#�=@��@[{/}##�#�#�\^WkK����_#�����k��_�հ�dmC}/=M3��ހ�Y_��PN�v�8��%##.�ѷ|��ǜ�##�HVFh#x#�k��Cp�L
��5�#x#

sanderj
Posts: 144
Joined: 10 Feb 2014, 21:46

Re: TLS-Socket: error:1408F119:SSL routines:SSL3_GET_RECORD:decryption failed or bad record mac

Post by sanderj » 19 Oct 2019, 10:42

NOTORIOUS VR wrote:
28 Sep 2019, 13:12


I will report back when I setup NZBget on a fresh install of Ubuntu in a new VM.
what is the result of that?

abutter
Posts: 5
Joined: 23 Oct 2019, 21:46

Re: TLS-Socket: error:1408F119:SSL routines:SSL3_GET_RECORD:decryption failed or bad record mac

Post by abutter » 07 Nov 2019, 22:23

Did you ever find a solution to this? I am seeing the exact same issue and am unable to find a solution...

abutter
Posts: 5
Joined: 23 Oct 2019, 21:46

Re: TLS-Socket: error:1408F119:SSL routines:SSL3_GET_RECORD:decryption failed or bad record mac

Post by abutter » 07 Nov 2019, 22:24

I have mine running in a docker on Unraid 6.6.7.

lasdjlasda
Posts: 16
Joined: 02 Mar 2015, 11:56

Re: TLS-Socket: error:1408F119:SSL routines:SSL3_GET_RECORD:decryption failed or bad record mac

Post by lasdjlasda » 08 Nov 2019, 07:17

I guess we are waiting for more information from you, NOTORIOUS VR or someone else.. post them logs!

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests