Slow download speed when loading from backup news-server.

Get help, report and discuss bugs.
Post Reply
ObaDobanan
Posts: 3
Joined: 13 Oct 2019, 15:53

Slow download speed when loading from backup news-server.

Post by ObaDobanan » 13 Oct 2019, 16:02

Hi!

I have a block account on a news-server that I am using as a backup. Whenever the backup server is used, I get very slow speeds (~ 5 MB/s), even if it is the only server besides my main server. When I use it as the main server I get my usual download speeds of ~ 100 MB/s. Could it be my timeout settings? I currently use:
Articel Retries: 1
ArticleInterval: 3
ArticleTimeout: 10
URL Retries: 1
URLInterval: 3
URLTimeout: 10
RemoteTimeout: 90
Any help is appreciated.

hugbug
Developer & Admin
Posts: 7430
Joined: 09 Sep 2008, 11:58
Location: Germany

Re: Slow download speed when loading from backup news-server.

Post by hugbug » 13 Oct 2019, 16:25

Some servers need more time to respond if they don't have article. Therefore it's probably your main server who slows down the process. You can test this: disable option HealthCheck, deactivate all servers except the main, try downloading nzb, which were slow in your previous test. Measure the time needed by server to fail the whole download. Is it progressing very fast (nothing is downloaded, the server only needs to respond with error code) or somewhat slow?

ObaDobanan
Posts: 3
Joined: 13 Oct 2019, 15:53

Re: Slow download speed when loading from backup news-server.

Post by ObaDobanan » 19 Oct 2019, 22:21

Sorry, it took me a while to try this, but I think you are right. Is there anything I can do to speed things up? Maybe a setting that switches to the backup server for all remaining articles as soon as the success rate is higher on the backup than on the main server?

Thanks for your help!

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests