Page 1 of 1

ErrNo 10054 / ErrNo 10060 with Newshosting

Posted: 07 Feb 2020, 04:52
by zaemon
Hello,

For some time now, I got repeatedly the following two errors:
- Could not receive data on socket from news.newshosting.com: ErrNo 10054, An existing connection was forcibly closed by the remote host.
- Could not receive data on socket from news.newshosting.com: ErrNo 10060, A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.

I've been using NZBGET 21.1-testing-r2311 and Newshosting servers for a long time now. I've tried to restart, change the servers (IPv4 only, for some reason I can't connect to IPv6 servers) and tested both SSL and no SSL. I checked that I was not using more connections that are allowed to me. I don't recall any change made recently in terms of software or hardware on my computer.

I can still grab articles but speed is drastically reduced.

Thanks in advance.

Re: ErrNo 10054 / ErrNo 10060 with Newshosting

Posted: 08 Feb 2020, 07:28
by sanderj
Windows sockets error codes. See https://docs.microsoft.com/en-us/window ... or-codes-2

Cause: network problems.

Re: ErrNo 10054 / ErrNo 10060 with Newshosting

Posted: 11 Feb 2020, 18:34
by unos
I had the problem a long time ago and it was due to cacert.pem problem, TLS certificate verification.
nzbget canĀ“t find this or you have a old one

Re: ErrNo 10054 / ErrNo 10060 with Newshosting

Posted: 13 Feb 2020, 20:30
by zaemon
Thanks to both of you.

At this point I suspect a network problem. I uninstalled my 10 GbE NIC and reinstalled it. So far so good.