Issues calling append - always get "AddTop" error

Get help, report and discuss bugs.
Post Reply
Posts: 7
Joined: 30 May 2017, 02:50

Issues calling append - always get "AddTop" error

Post by nzmike » 09 Apr 2020, 23:33

Hi hugubg (or anyone else).

I'm trying to call append with the JSON below but no matter what I try I get the same error:
"version" : "1.1",
"error" : {
"name" : "JSONRPCError",
"code" : 2,
"message" : "Invalid parameter (AddTop)"

This is my JSON - I believe I have all the parameters and in the right order. (I know the names are ignored, I just like to have them so I know I've got them all). So I can't work why I keep getting the AddTop error. Also, the API page says the parameter is "AddToTop" but even if I change the JSON to that I still get the same "AddTop" error above.


So I honestly don't know what's going on - why do I consistently get the same error no matter what parameters I try?

Developer & Admin
Posts: 7514
Joined: 09 Sep 2008, 11:58
Location: Germany

Re: Issues calling append - always get "AddTop" error

Post by hugbug » 09 Apr 2020, 23:50

Your Json is not valid. You can use any online tool for validation.
Hint: its's false, not False.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests