Sonarr & Radarr Unable to connect to NZBGet

Get help, report and discuss bugs.
Post Reply
Posts: 2
Joined: 14 Apr 2021, 05:35

Sonarr & Radarr Unable to connect to NZBGet

Post by DumDawG » 14 Apr 2021, 06:24

I have a unraid server that has been running sonarr & radarr with nzbget along with a list of others for a couple months now, running smoothly (after some troubles ;D).

A couple days ago Pokemon was requested through ombi, and sonarr was having trouble searching. I didnt have the anime category configued on my indexers, which i have done now. But it has problems matching episodes and seasons and downloading the corect ones. so i set the profile to only download sd quality as the mismatched versions were all higher quality ones.

While i was working on the above problem, nzbget suddenly stopped recieving downlaod requests from sonarr, which i thought was weird. I went over to radarr to test if it could send download request and it too and troubles. After trying to reinstall sonarr and nzbget (with being from scratch and restored settings) the problem still persits.

When i run an auto search on sonarr, the activity tab gives a pending orange symbol with downlaod client unavailable.
In radarr it just says its currently downloading with no time bar.
When i manually select a download in either radarr/sonarr, the red failed cloud appears saying

"Unable to connect to NzbGet. Error getting response stream (ReadDoneAsync2): ReceiveFailure: ''" (which ive copied from the log)

if i go to "", the following appears

"version" : "1.1",
"error" : {
"name" : "JSONRPCError",
"code" : 1,
"message" : "Invalid procedure"

If i then go to the download client settings in either sonarr or radarr, running a test produces a tick.
I've tried changing the security details in nzbget, then changing them in sonarr/radarr.
if sonarr/radarr have the wrong details, the test still passes. (this does'nt make sense)

I have tried cahnging versions of both sonarr and nzbget, either downgrading or from develop to stable and vice versa.

I'll attach the logs for sonarr,radarr and nzbget.
(100.63 KiB) Downloaded 18 times
sonarr log.txt
(167.39 KiB) Downloaded 11 times
radarr log.txt
(220.67 KiB) Downloaded 12 times

Posts: 2
Joined: 14 Apr 2021, 05:35

Re: Sonarr & Radarr Unable to connect to NZBGet

Post by DumDawG » 14 Apr 2021, 16:00

For anyone experiencing the same issue.

I did a fresh reinstall of nzbget, this time i didnt import my backedup settings. i manually input them.

Everything is now working as intended.

Post Reply

Who is online

Users browsing this forum: No registered users and 8 guests