Having trouble with external access

Get help, report and discuss bugs.
Post Reply
AtariBaby
Posts: 15
Joined: 08 May 2021, 16:42

Having trouble with external access

Post by AtariBaby » 09 May 2021, 02:00

I’d like to access nzbget outside my LAN, like I do my other usenet web apps. Here’s what I did:

Opened port 6789 on the firewall and on Windows advanced firewall. Same as I did with the others.

But when I try that the web page just spins for ages and times out.

There are some settings related to this but having trouble figuring out what to put in those fields.

A little help?

hugbug
Developer & Admin
Posts: 7601
Joined: 09 Sep 2008, 11:58
Location: Germany

Re: Having trouble with external access

Post by hugbug » 09 May 2021, 11:45

If you can access nzbget from another computer in your local network (for example from a phone), then nzbget and Windows are configured properly. Now you need to configure your router to pass requests from the Internet to your Windows PC.

AtariBaby
Posts: 15
Joined: 08 May 2021, 16:42

Re: Having trouble with external access

Post by AtariBaby » 09 May 2021, 15:02

Ah so good clarity there. I actually cannot access it via another computer on the local network. Sorry for not describing that well. I can however access all my other services: Radarr, sab, sonarr, etc.

hugbug
Developer & Admin
Posts: 7601
Joined: 09 Sep 2008, 11:58
Location: Germany

Re: Having trouble with external access

Post by hugbug » 09 May 2021, 15:40

How option "ControlIP" in NZBGet is set? It should not be 127.0.0.1. If it is - change it to 0.0.0.0.
If it still doesn't work the issue is definitely in Firewall settings.

AtariBaby
Posts: 15
Joined: 08 May 2021, 16:42

Re: Having trouble with external access

Post by AtariBaby » 09 May 2021, 16:32

Before I had the actual internal IP. I changed it 0’s and still can’t access it. I’ll try firewall rules again.

AtariBaby
Posts: 15
Joined: 08 May 2021, 16:42

Re: Having trouble with external access

Post by AtariBaby » 09 May 2021, 16:59

Oh damn, windows firewall or something else apparently reacted and created it’s own blocking rules. I changed them to allow and now I’m accessing it. Thank you!

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests