'Invalid option a' error on startup

Get help, report and discuss bugs.
Post Reply
iaTa
Posts: 5
Joined: 09 Mar 2019, 18:21

'Invalid option a' error on startup

Post by iaTa » 31 Oct 2021, 14:39

NZBGet has all of a sudden stopped loading during Windows startup and instead displays a console window with 'Invalid option a'.

I found the NZBGet startup command from the Windows registry and ran it manually:

"C:\Program Files\NZBGet\nzbget.exe" -s -app -auto

If -app or -auto are specified I see the 'Invalid option a' error.

The server loads fine in a console window if I only specify -s.

I'm running 21.2-testing-r2333 on Windows 11 and have tried an in place install over the top.

Any ideas why the exe no longer accepts -app -auto?

hugbug
Developer & Admin
Posts: 7638
Joined: 09 Sep 2008, 11:58
Location: Germany

Re: 'Invalid option a' error on startup

Post by hugbug » 31 Oct 2021, 15:54

Just start the exe from explorer (not from console) to start it with tray icon.

iaTa
Posts: 5
Joined: 09 Mar 2019, 18:21

Re: 'Invalid option a' error on startup

Post by iaTa » 31 Oct 2021, 16:14

If I do that a console windows flashes up very quickly and NZBGet doesn't start.

It looks like it's displaying the NZBGet usage instructions.

mempf
Posts: 1
Joined: 07 Nov 2021, 04:29

Re: 'Invalid option a' error on startup

Post by mempf » 07 Nov 2021, 04:30

I ran into this issue as well. It turned out to be caused by switching my default windows terminal app to the new windows terminal instead of command prompt.

jani
Posts: 7
Joined: 25 Jul 2013, 11:38

Re: 'Invalid option a' error on startup

Post by jani » 07 Nov 2021, 11:15

hugbug wrote:
31 Oct 2021, 15:54
Just start the exe from explorer (not from console) to start it with tray icon.
But I'd like to autostart NZBGet when Windows starts and I log in.
mempf wrote:
07 Nov 2021, 04:30
I ran into this issue as well. It turned out to be caused by switching my default windows terminal app to the new windows terminal instead of command prompt.
Ah, good thinking! I'm having this problem as well on Windows 11 and the new Windows Terminal v1.11 set as the default console host (mentioned in the release notes). It seems NZBGet tries to be a little too clever where it is launched from?

iaTa
Posts: 5
Joined: 09 Mar 2019, 18:21

Re: 'Invalid option a' error on startup

Post by iaTa » 07 Nov 2021, 18:41

Good catch mempf, switched back to Windows Console Host as default and NZBGet starts as expected.

The latest version of Windows Terminal will present first-time Windows 11 users with an information popup about changing their default terminal to WT so I would assume quite a few users will be seeing this issue soon when they switch over.

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests