Permission issues that aren't permissions based?

Get help, report and discuss bugs.
Post Reply
Posts: 1
Joined: 10 Jan 2022, 12:56

Permission issues that aren't permissions based?

Post by Azmiuth » 10 Jan 2022, 16:42

I have nzbget running for my Father in Law. A synology unit of some kind, but running docker (which I'm used to).

Got a call saying everything was failing from Sonarr and Radarr, its been running since late December. 

Turns out the issues seemed to be DNS resolution of the usenet server. Something without an obvious fix as the Test Connection always came back with Success.

In trying to resolve I then ran into other problems which I can't work out. When adding a nzb manually I get an immediate error and the log says "Could not create file /downloads/tmp/nzb-1.tmp".

The /downloads folder is a mapped path in docker, I've tried many combos of permissions, with the Downloads folder and all sub dirs set to chmod 777. I've set puid and pgid to 0 for the container. Also ticked a synology docker tick box saying 'run with highest privilege'. 

The odd thing is that nzbget does actually create the file on disk - the exact path in the error /downloads/tmp/nzb-1.tmp, but it does seem to be empty.

I add anther file, same error but this time nzb-2.tmp etc

I've had plenty of errors in my own systems, with incorrect mappings and permissions errors common but I just can't get this error.

States it can't write the file, but then goes ahead and creates the file at least.

Any idea what could cause this, or the initial dns lookup error? 

Post Reply

Who is online

Users browsing this forum: No registered users and 55 guests