Par repair on split avi

Get help, report and discuss bugs.
Post Reply
nobody

Par repair on split avi

Post by nobody » 11 Feb 2008, 00:14

Some folks post split avi parts instead of rars. The avi parts download fine

INFOSuccessfully downloaded ....foo.avi.001

The par2's don't decode

WARNINGDecoding ...foo.avi.par2 [1/1] failed: article incomplete

I'm guessing that the pars are generated from foo.avi before it is split. Par2 can both join the parts and repair the avi with "par2 r *.par2 *". The parts are treated as broken/extra files (the trailing "*").

I manually downloaded the par2 and repaired/joined the avi parts. I did this while NZBGet was still trying to fetch the avi.par2 (I forgot to change my 120 second retry). It looks like NZBGet found the par2 and foo.avi I downloaded/created.

INFOCollection <nzb> completely downloaded
INFOQueueing foo.avi for par-check
INFOChecking pars foo.avi
INFOVerifying foo.avi
ERRORCould not verify foo.avi:

hugbug

RE: Par repair on split avi

Post by hugbug » 11 Feb 2008, 08:17

The message "WARNING Decoding ...foo.avi.par2 [1/1] failed: article incomplete" indicates, that artice-downloader could not download the file. This problem has nothing to do with splitted avis.

Since the par2-file was not successfully downloaded the par-check failed (ERROR Could not verify foo.avi).

Could you please send me the nzb-file for test?

hugbug

RE: Par repair on split avi

Post by hugbug » 12 Feb 2008, 19:32

Thanks for the file and for the explanation on trailing "*".

I checked the nzb-file.

1. The main par2-file was damaged and could not be used for par-check. This results in error "Could not verify foo.avi" (your first post).

=> TODO-1: par-checker could be smarter and could unpause additional par2-files and try again then.


2. The problem with splitted avi-files is confirmed. Even when I unpaused the additional par2-files manually, par-check failed with the message "ERROR Repair failed for foo.avi: not enough par-blocks, 631 block(s) needed, but 53 block(s) available".

=> TODO-2: I need to add a special processing for splitted files to load them into par-checker manually or to relaunch the par-checker with trailing "*".

nobody

RE: Par repair on split avi

Post by nobody » 12 Feb 2008, 21:13

I downloaded the main par2 with BNR2 and used it to successfully reassemble the avi. I also sent you an mp3 nzb that fails (also downloads fine w/ BNR2). IIRC, all the split avi par2 files and all unrared mp3 downloads fail (at least the ones I tried, add multiple mp3's and it gets worse) with the same message - failed: article incomplete.

I always use a naked wildcard in a temp directory because its easier for me (all BNR2 partials are foo.rar<seg>-<seg>). If you included partial/broken files in all par2 repairs, the _broken issue would be moot. Would par2 r <partial name>*.par2 <partial name>* cover all the bases?

hugbug

RE: Par repair on split avi

Post by hugbug » 14 Feb 2008, 08:17

The main par2-file was encoded using a little bit different format, that confused the internal decoder.
This issue was fixed in r113.

Nevertheless both mentioned TODOs remain.

hugbug

RE: Par repair on split avi

Post by hugbug » 17 Feb 2008, 12:01

Update:
TODO-2 "processing of splitted files": completed in r119.

nobody

RE: Par repair on split avi

Post by nobody » 18 Feb 2008, 17:29

I tested this with r120. If nzbget is supposed to repair and join split avi's, the join isn't working. The test didn't need repair and manually running par2 on the archive successfully joined the parts. Split avi's are rare and I could do the join in post processing.

Sun Feb 17 19:55:48 2008INFOCollection ... completely downloaded
Sun Feb 17 19:55:48 2008INFOQueueing ...avi for par-check
Sun Feb 17 19:55:48 2008INFOChecking pars for ...avi
Sun Feb 17 19:55:48 2008INFOVerifying ...avi
Sun Feb 17 19:55:48 2008INFOVerifying file ...avi.par2
Sun Feb 17 19:55:49 2008WARNINGFile ...avi has 642 bad block(s) of total 642 block(s)
Sun Feb 17 19:55:49 2008INFONeed more 642 par-block(s) for ...avi
Sun Feb 17 19:55:49 2008ERRORRepair failed for ...avi: not enough par-blocks, 642 block(s) needed, but 64 block(s) available

hugbug

RE: Par repair on split avi

Post by hugbug » 18 Feb 2008, 18:02

Yes, the avi-file should have been repaired and joined.

Could it be that you run the old exe-file?
The new version should print "WARNING File ....avi with 642 block(s) is missing" instead of "WARNING File ...avi has 642 bad block(s) of total 642 block(s)".

Could you please test again and if it still not working send me the nzb-file?

nobody

RE: Par repair on split avi

Post by nobody » 18 Feb 2008, 18:04

Yikes. I'm not sure if I actually installed r120 yet. Is it possible to get the svn version included with the -v switch? I'll retest.

nobody

RE: Par repair on split avi

Post by nobody » 18 Feb 2008, 19:26

My bad. I had made v120, but had stuff in the queue and forgot to install it. I retested and it works great. Thanks.

Post Reply

Who is online

Users browsing this forum: No registered users and 8 guests