[SQS-Script] Completion-Propagation/DMCA/Retention check

Share your scripts or request scripts with specific features.
Forum rules
Please keep the forum clean - one topic per script. Questions not related to a specific script should be posted in Support forum.
Crowley
Posts: 30
Joined: 22 Nov 2016, 09:43

Re: [SQS-Script] Completion-Propagation/DMCA/Retention check

Post by Crowley » 27 Nov 2016, 19:58

I have not had the previous error again, but I'm getting a new one:

Code: Select all

ERROR	Completion: No news servers after filtering, skipping completion check, NZBs will remain paused in queue. Check your settings!
I tried the main/fill servers option but it seems to work only partly. Weird thing is, it will give that error a few times but eventually it works. That is the only relevant line in the log with verbose on, it will not start the check.
Attachments
nzb.PNG

dagoob
Posts: 21
Joined: 15 Jan 2016, 23:27

Re: [SQS-Script] Completion-Propagation/DMCA/Retention check

Post by dagoob » 27 Nov 2016, 20:08

@Crowley The servers are numbered from 1, not 0?

Speaking of which, I noticed that if the last server in a check is skipped then the failure_ratio is returned as 0% even if that's not the case.

I believe

Code: Select all

        failed_ratio = 0
(line 1009) should be after:

Code: Select all

        if conn_err[num_server] >= num_conn:
            print '[WARNING] Skipping server: ' + host
            num_server += 1
            continue
(lines 1015-1018) in check_failure_status().

Crowley
Posts: 30
Joined: 22 Nov 2016, 09:43

Re: [SQS-Script] Completion-Propagation/DMCA/Retention check

Post by Crowley » 27 Nov 2016, 21:32

dagoob wrote:@Crowley The servers are numbered from 1, not 0?
They are from 0, see attached image.
Attachments
nzb2.PNG

kloaknet
Posts: 336
Joined: 23 Jul 2014, 08:52

Re: [SQS-Script] Completion-Propagation/DMCA/Retention check

Post by kloaknet » 27 Nov 2016, 21:42

@Crowley, I think your issue is caused by that the server list should be:

0, 1

instead of

0, 1,

so a comma less should do it.

Have tried to reproduce your issue, and I think I know when it occurs now, but I dont get exactly yet why. I could patch it, but then the cause is not resolved. For the issue of fovert i think have found a solution, based on what I think did go wrong without the logs, and will upload a test script tomorrow. First i want to see if it survives a night doing stuff.

@dagoob, thanks for looking into the code, will look into the stuff you noticed as well.

Crowley
Posts: 30
Joined: 22 Nov 2016, 09:43

Re: [SQS-Script] Completion-Propagation/DMCA/Retention check

Post by Crowley » 27 Nov 2016, 22:31

Ok, so I changed it to "Server: 0," and "Fill Servers: 1, 2". With the first test file at least that seems to have fixed it. Thanks.

dagoob
Posts: 21
Joined: 15 Jan 2016, 23:27

Re: [SQS-Script] Completion-Propagation/DMCA/Retention check

Post by dagoob » 28 Nov 2016, 05:01

Crowley wrote:They are from 0, see attached image.
The level number isn't the same as the server number. Look at your first image again: "News-server numbers are equal to the server numbering in the NZBget settings on the NEWS-SERVERS tab." (emphasis mine).

Are you seeing the expected servers being checked if you turn on verbose logging for the completion script? (Which is what really matters)

Crowley
Posts: 30
Joined: 22 Nov 2016, 09:43

Re: [SQS-Script] Completion-Propagation/DMCA/Retention check

Post by Crowley » 28 Nov 2016, 09:38

dagoob wrote:
Crowley wrote:They are from 0, see attached image.
The level number isn't the same as the server number. Look at your first image again: "News-server numbers are equal to the server numbering in the NZBget settings on the NEWS-SERVERS tab." (emphasis mine).

Are you seeing the expected servers being checked if you turn on verbose logging for the completion script? (Which is what really matters)
You are right of course, now I understood what you meant. And indeed it failed again, hopefully this fixes it.

kloaknet
Posts: 336
Joined: 23 Jul 2014, 08:52

Re: [SQS-Script] Completion-Propagation/DMCA/Retention check

Post by kloaknet » 28 Nov 2016, 17:02

@Crowley: each comma in the list of (fill) servers makes the script assume there will be a next one, so if you only have 1 main server it should be:

Code: Select all

1
if you have multiple it should be:

Code: Select all

1,2
@dagoob: the position of line 1009 is not an issue for the code after the block between lines 1015 and 1018, as the actual looping over the articles happens from line 1025. So if one of the servers has issues on all connections, it will continue to the next one in the for loop starting at line 999.

@fovert: below an updated script that should solve your issue for the DUPE handling from items in the history. It also includes some logging (spamming) feature for the issue of Crowley for the to large send_articles parameter. this is at line 1092 and 1093, and the code there can simply be replaced by 2 enters.

@Crowley: below an updated script that spams a lot of data. Your issue could be related to the while loop between lines 1083 and 1089, the if statement at lines 1126 to 1131, resulting in a too large index number on line 1094. I can patch it, but I dont like that, I just want to solve the cause of it, please run it with verbose on. I will try to narrow the issue down within a week.
Completion.py
This is just a test version with a lot of spamming. Please use v 0.2.8 instead
(68.98 KiB) Downloaded 144 times

Crowley
Posts: 30
Joined: 22 Nov 2016, 09:43

Re: [SQS-Script] Completion-Propagation/DMCA/Retention check

Post by Crowley » 28 Nov 2016, 17:10

Ok I corrected my server settings. The test script is running and I will report back if the original error happens again.

dagoob
Posts: 21
Joined: 15 Jan 2016, 23:27

Re: [SQS-Script] Completion-Propagation/DMCA/Retention check

Post by dagoob » 28 Nov 2016, 23:01

kloaknet wrote:@dagoob: the position of line 1009 is not an issue for the code after the block between lines 1015 and 1018, as the actual looping over the articles happens from line 1025. So if one of the servers has issues on all connections, it will continue to the next one in the for loop starting at line 999.
The problem occurs when if the last server is skipped. You've reset failed_ratio to zero—which is fine if the last server is checked as that would give the correct final ratio—but skipping it returns the ratio as 0% rather than the correct amount.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests