NZBget for Synology

Get help, report and discuss bugs.
abenc85
Posts: 1
Joined: 23 Mar 2018, 08:21

Re: NZBget for Synology

Post by abenc85 » 23 Mar 2018, 08:26

Hello,

There appears to have been incremental NZBGet updates on my Synology DSM over the past few days; is this intentional or an issue with my machine downloading the packages?

Also - I keep getting an issue with permissions inheritance. I believe sonarr and radarr need the files to have permissions from the sc-downloads group, however, when they are fully extracted by NZBGet the final directory in the dst folder has this permission but the file itself only has sc-nzbget group permissions.

This means that the file remains stuck until I manually apply sc-downloads permissions (i reapply it for the directory to cascade down) or manually import it via sonarr/radarr.

Is anyone aware of this issue and what I can do to fix it? Is there a solution available within the Synology UI?

oranjeboven
Posts: 1
Joined: 23 Mar 2018, 09:58

Re: NZBget for Synology

Post by oranjeboven » 23 Mar 2018, 10:04

After applying the latest update (both stable and testing) Couchpotato doesn't connect to NZBget any more. Sonarr reports that the connection is successful, and I cannot find errors in the way CP is setup. Why should it anyway since it worked up to yesterday.

From CP-log: ERROR [o.core.downloaders.nzbget] NZBGet is not responding. Please ensure that NZBGet is running and host setting is correct.

wezman
Posts: 1
Joined: 26 Mar 2018, 14:54

Re: NZBget for Synology

Post by wezman » 26 Mar 2018, 15:01

Since updating to the latest SynoCommunity version 20180322-25, nzbget will no longer start, with the error 'Failed to run the package service''

Anyone have any ideas?

CyberPunk
Posts: 2
Joined: 07 Apr 2018, 01:32

Re: NZBget for Synology

Post by CyberPunk » 07 Apr 2018, 01:42

I have the same or a similar problem as abenc85.

I'm using sickrage and in postprocessing with nzbToSickbeard i get sometimes the error "Processing failed: File is locked for reading/writing"
After applying the permissions and starting postprocessing again the error is gone.
As mentioned above, the error appears only sometimes and i have no idea how to fix it.

Would be nice if anyone could help.

CyberPunk
Posts: 2
Joined: 07 Apr 2018, 01:32

Re: NZBget for Synology

Post by CyberPunk » 14 Apr 2018, 05:46

I found out that the permission problems only occur when nzbget renames rar files before unpacking them.
If files aren't renamed the permissions are okay.

As i couldn't find a solution in nzbget configuration or with synology, I ended up using the permissions.sh Script from this thread: https://forum.nzbget.net/viewtopic.php?t=835

psylance
Posts: 2
Joined: 15 May 2018, 03:36

Re: NZBget for Synology

Post by psylance » 15 May 2018, 03:53

Hi all, I followed al3x's instruction on page 2 and everything seems to work except for a noob problem of mine I believe.

The path I specified for MainDir is /volume1/homes/Joe/Download and for NzbDir is ${MainDir}/nzb

Download doesn't start even if I do a manual scan of the download folder. However if manually added the NZB file I get the following error => Could not move file /usr/local/nzbget/var/Download/tmp/nzb-5.tmp to /volume1/homes/Joe/Download/nzb/abcfile.nzb: Permission denied

If I specified the MainDir as ~/Download and do a manual nzb file add it works and downloaded file appears in /usr/local/nzbget/var/Download/Complete

Seems like it is defaulting to the /usr/local directory how can I change it to the MainDir I specified initially above please?

psylance
Posts: 2
Joined: 15 May 2018, 03:36

Re: NZBget for Synology

Post by psylance » 20 May 2018, 08:24

Any ideas anyone?

Steggl
Posts: 23
Joined: 11 Dec 2013, 15:55
Contact:

Re: NZBget for Synology

Post by Steggl » 22 Jul 2018, 17:03

oranjeboven wrote:
23 Mar 2018, 10:04
After applying the latest update (both stable and testing) Couchpotato doesn't connect to NZBget any more. Sonarr reports that the connection is successful, and I cannot find errors in the way CP is setup. Why should it anyway since it worked up to yesterday.

From CP-log: ERROR [o.core.downloaders.nzbget] NZBGet is not responding. Please ensure that NZBGet is running and host setting is correct.
Having the same issue here. Have you been able to fix it?

Steggl
Posts: 23
Joined: 11 Dec 2013, 15:55
Contact:

Re: NZBget for Synology

Post by Steggl » 23 Jul 2018, 08:40

Having the same issue with SickGear now too 😬 Wish that I could increase the debug level for nzbget as I am currently clueless.

cestlebon
Posts: 21
Joined: 11 Apr 2017, 20:01

Re: NZBget for Synology

Post by cestlebon » 23 Jul 2018, 11:53

I also had some errors with Sonarr connecting to nzbget (probably caused by a bug in the mono runtime of Sonarr). As a workaround I installed a let's encrypt certificate on my NAS and used it with nzbget.

Maybe this also helps with Sickrage and couchpotato (although they both don't use mono)?

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 7 guests